summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python3-pytz_2023.3.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/python/python3-pytz_2023.3.bb')
-rw-r--r--meta/recipes-devtools/python/python3-pytz_2023.3.bb36
1 files changed, 36 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python3-pytz_2023.3.bb b/meta/recipes-devtools/python/python3-pytz_2023.3.bb
new file mode 100644
index 0000000000..09fa26093f
--- /dev/null
+++ b/meta/recipes-devtools/python/python3-pytz_2023.3.bb
@@ -0,0 +1,36 @@
1SUMMARY = "World timezone definitions, modern and historical"
2HOMEPAGE = "http://pythonhosted.org/pytz"
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=1a67fc46c1b596cce5d21209bbe75999"
5
6inherit pypi setuptools3 ptest
7
8SRC_URI[sha256sum] = "1d8ce29db189191fb55338ee6d0387d82ab59f3d00eac103412d64e0ebd0c588"
9
10RDEPENDS:${PN}:class-target += "\
11 ${PYTHON_PN}-datetime \
12 ${PYTHON_PN}-doctest \
13 ${PYTHON_PN}-io \
14 ${PYTHON_PN}-pickle \
15 ${PYTHON_PN}-pprint \
16 ${PYTHON_PN}-threading \
17"
18
19BBCLASSEXTEND = "native nativesdk"
20
21SRC_URI += " \
22 file://run-ptest \
23"
24
25RDEPENDS:${PN}-ptest += " \
26 ${PYTHON_PN}-pytest \
27 ${PYTHON_PN}-unittest-automake-output \
28"
29
30do_install_ptest() {
31 install -d ${D}${PTEST_PATH}/pytz
32 install -d ${D}${PTEST_PATH}/pytz/tests
33 cp -rf ${S}/pytz/tests/* ${D}${PTEST_PATH}/pytz/tests/
34 cp -f ${S}/README.rst ${D}${PTEST_PATH}/
35
36}