summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python3-pytest_8.2.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/python/python3-pytest_8.2.0.bb')
-rw-r--r--meta/recipes-devtools/python/python3-pytest_8.2.0.bb41
1 files changed, 41 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python3-pytest_8.2.0.bb b/meta/recipes-devtools/python/python3-pytest_8.2.0.bb
new file mode 100644
index 0000000000..1e6674079f
--- /dev/null
+++ b/meta/recipes-devtools/python/python3-pytest_8.2.0.bb
@@ -0,0 +1,41 @@
1SUMMARY = "Simple powerful testing with python"
2HOMEPAGE = "https://pypi.org/project/pytest/"
3DESCRIPTION = "The pytest framework makes it easy to write small tests, yet scales to support complex functional testing for applications and libraries."
4
5LICENSE = "MIT"
6LIC_FILES_CHKSUM = "file://LICENSE;md5=bd27e41b6550fe0fc45356d1d81ee37c"
7
8SRC_URI[sha256sum] = "d507d4482197eac0ba2bae2e9babf0672eb333017bcedaa5fb1a3d42c1174b3f"
9
10DEPENDS += "python3-setuptools-scm-native"
11
12inherit update-alternatives pypi python_setuptools_build_meta
13
14RDEPENDS:${PN} += " \
15 python3-atomicwrites \
16 python3-attrs \
17 python3-debugger \
18 python3-doctest \
19 python3-importlib-metadata \
20 python3-iniconfig \
21 python3-json \
22 python3-more-itertools \
23 python3-packaging \
24 python3-pathlib2 \
25 python3-pluggy \
26 python3-py \
27 python3-setuptools \
28 python3-six \
29 python3-tomllib \
30 python3-wcwidth \
31"
32
33ALTERNATIVE:${PN} += "py.test pytest"
34
35NATIVE_LINK_NAME[pytest] = "${bindir}/pytest"
36ALTERNATIVE_TARGET[pytest] = "${bindir}/pytest"
37
38ALTERNATIVE_LINK_NAME[py.test] = "${bindir}/py.test"
39ALTERNATIVE_TARGET[py.test] = "${bindir}/py.test"
40
41BBCLASSEXTEND = "native nativesdk"