summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python3-pytest_6.2.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/python/python3-pytest_6.2.2.bb')
-rw-r--r--meta/recipes-devtools/python/python3-pytest_6.2.2.bb39
1 files changed, 0 insertions, 39 deletions
diff --git a/meta/recipes-devtools/python/python3-pytest_6.2.2.bb b/meta/recipes-devtools/python/python3-pytest_6.2.2.bb
deleted file mode 100644
index 392c20d039..0000000000
--- a/meta/recipes-devtools/python/python3-pytest_6.2.2.bb
+++ /dev/null
@@ -1,39 +0,0 @@
1SUMMARY = "Simple powerful testing with python"
2
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=81eb9f71d006c6b268cf4388e3c98f7b"
5
6SRC_URI_append = " file://0001-setup.py-remove-the-setup_requires-for-setuptools-scm.patch "
7
8SRC_URI[sha256sum] = "9d1edf9e7d0b84d72ea3dbcdfd22b35fb543a5e8f2a60092dd578936bf63d7f9"
9
10inherit update-alternatives pypi setuptools3
11
12RDEPENDS_${PN}_class-target += " \
13 ${PYTHON_PN}-atomicwrites \
14 ${PYTHON_PN}-attrs \
15 ${PYTHON_PN}-debugger \
16 ${PYTHON_PN}-doctest \
17 ${PYTHON_PN}-importlib-metadata \
18 ${PYTHON_PN}-iniconfig \
19 ${PYTHON_PN}-json \
20 ${PYTHON_PN}-more-itertools \
21 ${PYTHON_PN}-packaging \
22 ${PYTHON_PN}-pathlib2 \
23 ${PYTHON_PN}-pluggy \
24 ${PYTHON_PN}-py \
25 ${PYTHON_PN}-setuptools \
26 ${PYTHON_PN}-six \
27 ${PYTHON_PN}-toml \
28 ${PYTHON_PN}-wcwidth \
29"
30
31ALTERNATIVE_${PN} += "py.test pytest"
32
33NATIVE_LINK_NAME[pytest] = "${bindir}/pytest"
34ALTERNATIVE_TARGET[pytest] = "${bindir}/pytest"
35
36ALTERNATIVE_LINK_NAME[py.test] = "${bindir}/py.test"
37ALTERNATIVE_TARGET[py.test] = "${bindir}/py.test"
38
39BBCLASSEXTEND = "native nativesdk"