summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python3-pygobject_3.28.3.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/python/python3-pygobject_3.28.3.bb')
-rw-r--r--meta/recipes-devtools/python/python3-pygobject_3.28.3.bb29
1 files changed, 29 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python3-pygobject_3.28.3.bb b/meta/recipes-devtools/python/python3-pygobject_3.28.3.bb
new file mode 100644
index 0000000000..313af227b6
--- /dev/null
+++ b/meta/recipes-devtools/python/python3-pygobject_3.28.3.bb
@@ -0,0 +1,29 @@
1SUMMARY = "Python GObject bindings"
2SECTION = "devel/python"
3LICENSE = "LGPLv2.1"
4LIC_FILES_CHKSUM = "file://COPYING;md5=a916467b91076e631dd8edb7424769c7"
5
6inherit gnomebase distutils3-base gobject-introspection upstream-version-is-even
7
8DEPENDS += "python3 glib-2.0"
9
10SRCNAME="pygobject"
11SRC_URI = " \
12 http://ftp.gnome.org/pub/GNOME/sources/${SRCNAME}/${@gnome_verdir("${PV}")}/${SRCNAME}-${PV}.tar.xz \
13"
14
15SRC_URI[md5sum] = "3bac63c86bb963aa401f97859464aa90"
16SRC_URI[sha256sum] = "3dd3e21015d06e00482ea665fc1733b77e754a6ab656a5db5d7f7bfaf31ad0b0"
17
18S = "${WORKDIR}/${SRCNAME}-${PV}"
19
20PACKAGECONFIG ??= "${@bb.utils.contains_any('DISTRO_FEATURES', [ 'directfb', 'wayland', 'x11' ], 'cairo', '', d)}"
21
22# python3-pycairo is checked on configuration -> DEPENDS
23# we don't link against python3-pycairo -> RDEPENDS
24PACKAGECONFIG[cairo] = "--enable-cairo,--disable-cairo,cairo python3-pycairo, python3-pycairo"
25
26RDEPENDS_${PN} += "python3-setuptools"
27
28BBCLASSEXTEND = "native"
29PACKAGECONFIG_class-native = ""