summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python3-pycairo_1.19.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/python/python3-pycairo_1.19.0.bb')
-rw-r--r--meta/recipes-devtools/python/python3-pycairo_1.19.0.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python3-pycairo_1.19.0.bb b/meta/recipes-devtools/python/python3-pycairo_1.19.0.bb
new file mode 100644
index 0000000000..8f60834c17
--- /dev/null
+++ b/meta/recipes-devtools/python/python3-pycairo_1.19.0.bb
@@ -0,0 +1,27 @@
1SUMMARY = "Python bindings for the Cairo canvas library"
2HOMEPAGE = "http://cairographics.org/pycairo"
3BUGTRACKER = "http://bugs.freedesktop.org"
4SECTION = "python-devel"
5LICENSE = "LGPLv2.1 & MPLv1.1"
6LIC_FILES_CHKSUM = "file://COPYING;md5=f3713ca2c28d9312ad718520b6dc3eee \
7 file://COPYING-LGPL-2.1;md5=fad9b3332be894bab9bc501572864b29 \
8 file://COPYING-MPL-1.1;md5=bfe1f75d606912a4111c90743d6c7325"
9
10# cairo >= 1.14
11DEPENDS = "cairo python3"
12
13SRC_URI = "https://github.com/pygobject/pycairo/releases/download/v${PV}/pycairo-${PV}.tar.gz"
14UPSTREAM_CHECK_URI = "https://github.com/pygobject/pycairo/releases/"
15
16SRC_URI[md5sum] = "38b84416021640b01250c8f8ec4c52d4"
17SRC_URI[sha256sum] = "4f5ba9374a46c98729dd3727d993f5e17ed0286fd6738ed464fe4efa0612d19c"
18
19S = "${WORKDIR}/pycairo-${PV}"
20
21inherit meson pkgconfig
22
23CFLAGS += "-fPIC"
24
25BBCLASSEXTEND = "native"
26
27FILES_${PN} = "${PYTHON_SITEPACKAGES_DIR}/*"