summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python3-pycairo_1.10.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/python/python3-pycairo_1.10.0.bb')
-rw-r--r--meta/recipes-devtools/python/python3-pycairo_1.10.0.bb40
1 files changed, 40 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python3-pycairo_1.10.0.bb b/meta/recipes-devtools/python/python3-pycairo_1.10.0.bb
new file mode 100644
index 0000000000..f9031b3bca
--- /dev/null
+++ b/meta/recipes-devtools/python/python3-pycairo_1.10.0.bb
@@ -0,0 +1,40 @@
1SUMMARY = "Python bindings for the Cairo canvas library"
2HOMEPAGE = "http://cairographics.org/pycairo"
3BUGTRACKER = "http://bugs.freedesktop.org"
4SECTION = "python-devel"
5LICENSE = "LGPLv3"
6LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504 \
7 file://COPYING.LESSER;md5=e6a600fd5e1d9cbde2d983680233ad02"
8
9# cairo >= 1.8.8
10DEPENDS = "cairo"
11PR = "r2"
12
13SRC_URI = "http://cairographics.org/releases/pycairo-${PV}.tar.bz2"
14
15SRC_URI[md5sum] = "e6fd3f2f1e6a72e0db0868c4985669c5"
16SRC_URI[sha256sum] = "9aa4078e7eb5be583aeabbe8d87172797717f95e8c4338f0d4a17b683a7253be"
17
18S = "${WORKDIR}/pycairo-${PV}"
19
20inherit distutils3 pkgconfig
21
22BBCLASSEXTEND = "native"
23
24do_configure() {
25 PYTHON=${PYTHON} ./waf configure --prefix=${D}${prefix} --libdir=${D}${libdir}
26}
27
28do_compile() {
29 ./waf build ${PARALLEL_MAKE}
30}
31
32do_install() {
33 ./waf install
34 sed \
35 -e 's:@prefix@:${prefix}:' \
36 -e 's:@VERSION@:${PV}:' \
37 -e 's:@includedir@:${includedir}:' \
38 py3cairo.pc.in > py3cairo.pc
39 install -m 0644 py3cairo.pc ${D}${libdir}/pkgconfig/
40}