summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python3-psutil_5.9.3.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/python/python3-psutil_5.9.3.bb')
-rw-r--r--meta/recipes-devtools/python/python3-psutil_5.9.3.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python3-psutil_5.9.3.bb b/meta/recipes-devtools/python/python3-psutil_5.9.3.bb
new file mode 100644
index 0000000000..f099803150
--- /dev/null
+++ b/meta/recipes-devtools/python/python3-psutil_5.9.3.bb
@@ -0,0 +1,27 @@
1SUMMARY = "A cross-platform process and system utilities module for Python"
2LICENSE = "BSD-3-Clause"
3LIC_FILES_CHKSUM = "file://LICENSE;md5=e35fd9f271d19d5f742f20a9d1f8bb8b"
4HOMEPAGE = "https://pypi.org/project/psutil/"
5
6SRC_URI[sha256sum] = "7ccfcdfea4fc4b0a02ca2c31de7fcd186beb9cff8207800e14ab66f79c773af6"
7
8inherit pypi setuptools3
9
10PACKAGES =+ "${PN}-tests"
11
12FILES:${PN}-tests += " \
13 ${PYTHON_SITEPACKAGES_DIR}/psutil/test* \
14 ${PYTHON_SITEPACKAGES_DIR}/psutil/__pycache__/test* \
15"
16
17
18RDEPENDS:${PN} += " \
19 ${PYTHON_PN}-shell \
20 ${PYTHON_PN}-threading \
21 ${PYTHON_PN}-xml \
22 ${PYTHON_PN}-netclient \
23 ${PYTHON_PN}-ctypes \
24 ${PYTHON_PN}-resource \
25"
26
27BBCLASSEXTEND = "native nativesdk"