summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python3-pip_9.0.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/python/python3-pip_9.0.1.bb')
-rw-r--r--meta/recipes-devtools/python/python3-pip_9.0.1.bb13
1 files changed, 3 insertions, 10 deletions
diff --git a/meta/recipes-devtools/python/python3-pip_9.0.1.bb b/meta/recipes-devtools/python/python3-pip_9.0.1.bb
index 9b907a2631..4ce13da410 100644
--- a/meta/recipes-devtools/python/python3-pip_9.0.1.bb
+++ b/meta/recipes-devtools/python/python3-pip_9.0.1.bb
@@ -1,22 +1,15 @@
1SUMMARY = "The PyPA recommended tool for installing Python packages" 1SUMMARY = "The PyPA recommended tool for installing Python packages"
2sHOMEPAGEsss = "https://pypi.python.org/pypi/pip" 2HOMEPAGE = "https://pypi.python.org/pypi/pip"
3SECTION = "devel/python" 3SECTION = "devel/python"
4LICENSE = "MIT" 4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=25fba45109565f87de20bae85bc39452" 5LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=25fba45109565f87de20bae85bc39452"
6 6
7SRCNAME = "pip"
8DEPENDS += "python3 python3-setuptools-native" 7DEPENDS += "python3 python3-setuptools-native"
9 8
10SRC_URI = "https://files.pythonhosted.org/packages/source/p/${SRCNAME}/${SRCNAME}-${PV}.tar.gz"
11
12SRC_URI[md5sum] = "35f01da33009719497f01a4ba69d63c9" 9SRC_URI[md5sum] = "35f01da33009719497f01a4ba69d63c9"
13SRC_URI[sha256sum] = "09f243e1a7b461f654c26a725fa373211bb7ff17a9300058b205c61658ca940d" 10SRC_URI[sha256sum] = "09f243e1a7b461f654c26a725fa373211bb7ff17a9300058b205c61658ca940d"
14 11
15UPSTREAM_CHECK_URI = "https://pypi.python.org/pypi/pip" 12inherit pypi distutils3
16
17S = "${WORKDIR}/${SRCNAME}-${PV}"
18
19inherit distutils3
20 13
21DISTUTILS_INSTALL_ARGS += "--install-lib=${D}${PYTHON_SITEPACKAGES_DIR}" 14DISTUTILS_INSTALL_ARGS += "--install-lib=${D}${PYTHON_SITEPACKAGES_DIR}"
22 15
@@ -33,7 +26,7 @@ do_install_append() {
33 rm ${D}/${bindir}/pip 26 rm ${D}/${bindir}/pip
34 27
35 # Installed eggs need to be passed directly to the interpreter via a pth file 28 # Installed eggs need to be passed directly to the interpreter via a pth file
36 echo "./${SRCNAME}-${PV}-py${PYTHON_BASEVERSION}.egg" > ${D}${PYTHON_SITEPACKAGES_DIR}/${SRCNAME}-${PV}.pth 29 echo "./${PYPI_PACKAGE}-${PV}-py${PYTHON_BASEVERSION}.egg" > ${D}${PYTHON_SITEPACKAGES_DIR}/${PYPI_PACKAGE}-${PV}.pth
37 30
38 # Make sure we use /usr/bin/env python3 31 # Make sure we use /usr/bin/env python3
39 for PYTHSCRIPT in `grep -rIl ${bindir} ${D}${bindir}/pip3*`; do 32 for PYTHSCRIPT in `grep -rIl ${bindir} ${D}${bindir}/pip3*`; do