summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python3-pip_8.1.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/python/python3-pip_8.1.2.bb')
-rw-r--r--meta/recipes-devtools/python/python3-pip_8.1.2.bb47
1 files changed, 47 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python3-pip_8.1.2.bb b/meta/recipes-devtools/python/python3-pip_8.1.2.bb
new file mode 100644
index 0000000000..e319dff675
--- /dev/null
+++ b/meta/recipes-devtools/python/python3-pip_8.1.2.bb
@@ -0,0 +1,47 @@
1SUMMARY = "The PyPA recommended tool for installing Python packages"
2sHOMEPAGEsss = "https://pypi.python.org/pypi/pip"
3SECTION = "devel/python"
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=25fba45109565f87de20bae85bc39452"
6
7SRCNAME = "pip"
8DEPENDS += "python3 python3-setuptools-native"
9
10SRC_URI = "https://files.pythonhosted.org/packages/source/p/${SRCNAME}/${SRCNAME}-${PV}.tar.gz"
11
12SRC_URI[md5sum] = "87083c0b9867963b29f7aba3613e8f4a"
13SRC_URI[sha256sum] = "4d24b03ffa67638a3fa931c09fd9e0273ffa904e95ebebe7d4b1a54c93d7b732"
14
15UPSTREAM_CHECK_URI = "https://pypi.python.org/pypi/pip"
16
17S = "${WORKDIR}/${SRCNAME}-${PV}"
18
19inherit distutils3
20
21DISTUTILS_INSTALL_ARGS += "--install-lib=${D}${libdir}/${PYTHON_DIR}/site-packages"
22
23do_install_prepend() {
24 install -d ${D}/${libdir}/${PYTHON_DIR}/site-packages
25}
26
27# Use setuptools site.py instead, avoid shared state issue
28do_install_append() {
29 rm ${D}/${libdir}/${PYTHON_DIR}/site-packages/site.py
30 rm ${D}/${libdir}/${PYTHON_DIR}/site-packages/__pycache__/site.cpython-*.pyc
31
32 # Install as pip3 and leave pip2 as default
33 rm ${D}/${bindir}/pip
34
35 # Installed eggs need to be passed directly to the interpreter via a pth file
36 echo "./${SRCNAME}-${PV}-py${PYTHON_BASEVERSION}.egg" > ${D}${PYTHON_SITEPACKAGES_DIR}/${SRCNAME}-${PV}.pth
37}
38
39RDEPENDS_${PN} = "\
40 python3-compile \
41 python3-io \
42 python3-json \
43 python3-netserver \
44 python3-setuptools \
45 python3-unixadmin \
46 python3-xmlrpc \
47"