summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python3-pip_7.1.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/python/python3-pip_7.1.2.bb')
-rw-r--r--meta/recipes-devtools/python/python3-pip_7.1.2.bb48
1 files changed, 48 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python3-pip_7.1.2.bb b/meta/recipes-devtools/python/python3-pip_7.1.2.bb
new file mode 100644
index 0000000000..297b3510d5
--- /dev/null
+++ b/meta/recipes-devtools/python/python3-pip_7.1.2.bb
@@ -0,0 +1,48 @@
1SUMMARY = "The PyPA recommended tool for installing Python packages"
2sHOMEPAGEsss = "https://pypi.python.org/pypi/pip"
3SECTION = "devel/python"
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=45665b53032c02b35e29ddab8e61fa91"
6
7SRCNAME = "pip"
8DEPENDS += "python3 python3-setuptools-native"
9
10SRC_URI = " \
11 http://pypi.python.org/packages/source/p/${SRCNAME}/${SRCNAME}-${PV}.tar.gz \
12"
13SRC_URI[md5sum] = "3823d2343d9f3aaab21cf9c917710196"
14SRC_URI[sha256sum] = "ca047986f0528cfa975a14fb9f7f106271d4e0c3fe1ddced6c1db2e7ae57a477"
15
16UPSTREAM_CHECK_URI = "https://pypi.python.org/pypi/pip"
17
18S = "${WORKDIR}/${SRCNAME}-${PV}"
19
20inherit distutils3
21
22DISTUTILS_INSTALL_ARGS += "--install-lib=${D}${libdir}/${PYTHON_DIR}/site-packages"
23
24do_install_prepend() {
25 install -d ${D}/${libdir}/${PYTHON_DIR}/site-packages
26}
27
28# Use setuptools site.py instead, avoid shared state issue
29do_install_append() {
30 rm ${D}/${libdir}/${PYTHON_DIR}/site-packages/site.py
31 rm ${D}/${libdir}/${PYTHON_DIR}/site-packages/__pycache__/site.cpython-*.pyc
32
33 # Install as pip3 and leave pip2 as default
34 rm ${D}/${bindir}/pip
35
36 # Installed eggs need to be passed directly to the interpreter via a pth file
37 echo "./${SRCNAME}-${PV}-py${PYTHON_BASEVERSION}.egg" > ${D}${PYTHON_SITEPACKAGES_DIR}/${SRCNAME}-${PV}.pth
38}
39
40RDEPENDS_${PN} = "\
41 python3-compile \
42 python3-io \
43 python3-json \
44 python3-netserver \
45 python3-setuptools \
46 python3-unixadmin \
47 python3-xmlrpc \
48"