summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python3-pip_21.1.3.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/python/python3-pip_21.1.3.bb')
-rw-r--r--meta/recipes-devtools/python/python3-pip_21.1.3.bb34
1 files changed, 34 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python3-pip_21.1.3.bb b/meta/recipes-devtools/python/python3-pip_21.1.3.bb
new file mode 100644
index 0000000000..239e83fced
--- /dev/null
+++ b/meta/recipes-devtools/python/python3-pip_21.1.3.bb
@@ -0,0 +1,34 @@
1SUMMARY = "The PyPA recommended tool for installing Python packages"
2HOMEPAGE = "https://pypi.org/project/pip"
3SECTION = "devel/python"
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=c4fa2b50f55649f43060fa04b0919b9b"
6
7DEPENDS += "python3 python3-setuptools-native"
8
9inherit pypi distutils3
10
11SRC_URI += "file://0001-change-shebang-to-python3.patch"
12
13SRC_URI[md5sum] = "e459d41a10ce33688b5d389216a8876f"
14SRC_URI[sha256sum] = "b5b1eb91b36894bd01b8e5a56a422c2f3838573da0b0a1c63a096bb454e3b23f"
15
16do_install_append() {
17 # Install as pip3 and leave pip2 as default
18 rm ${D}/${bindir}/pip
19}
20
21RDEPENDS_${PN} = "\
22 python3-compile \
23 python3-io \
24 python3-html \
25 python3-json \
26 python3-multiprocessing \
27 python3-netserver \
28 python3-setuptools \
29 python3-unixadmin \
30 python3-xmlrpc \
31 python3-pickle \
32"
33
34BBCLASSEXTEND = "native nativesdk"