summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python3-pip_20.0.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/python/python3-pip_20.0.2.bb')
-rw-r--r--meta/recipes-devtools/python/python3-pip_20.0.2.bb31
1 files changed, 31 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python3-pip_20.0.2.bb b/meta/recipes-devtools/python/python3-pip_20.0.2.bb
new file mode 100644
index 0000000000..08738fb2f9
--- /dev/null
+++ b/meta/recipes-devtools/python/python3-pip_20.0.2.bb
@@ -0,0 +1,31 @@
1SUMMARY = "The PyPA recommended tool for installing Python packages"
2HOMEPAGE = "https://pypi.python.org/pypi/pip"
3SECTION = "devel/python"
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=8ba06d529c955048e5ddd7c45459eb2e"
6
7DEPENDS += "python3 python3-setuptools-native"
8
9SRC_URI[md5sum] = "7d42ba49b809604f0df3d55df1c3fd86"
10SRC_URI[sha256sum] = "7db0c8ea4c7ea51c8049640e8e6e7fde949de672bfa4949920675563a5a6967f"
11
12inherit pypi distutils3
13
14do_install_append() {
15 # Install as pip3 and leave pip2 as default
16 rm ${D}/${bindir}/pip
17}
18
19RDEPENDS_${PN} = "\
20 python3-compile \
21 python3-io \
22 python3-html \
23 python3-json \
24 python3-netserver \
25 python3-setuptools \
26 python3-unixadmin \
27 python3-xmlrpc \
28 python3-pickle \
29"
30
31BBCLASSEXTEND = "native nativesdk"