summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python3-pip_19.3.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/python/python3-pip_19.3.1.bb')
-rw-r--r--meta/recipes-devtools/python/python3-pip_19.3.1.bb31
1 files changed, 31 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python3-pip_19.3.1.bb b/meta/recipes-devtools/python/python3-pip_19.3.1.bb
new file mode 100644
index 0000000000..d27e6fce5c
--- /dev/null
+++ b/meta/recipes-devtools/python/python3-pip_19.3.1.bb
@@ -0,0 +1,31 @@
1SUMMARY = "The PyPA recommended tool for installing Python packages"
2HOMEPAGE = "https://pypi.python.org/pypi/pip"
3SECTION = "devel/python"
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=8ba06d529c955048e5ddd7c45459eb2e"
6
7DEPENDS += "python3 python3-setuptools-native"
8
9SRC_URI[md5sum] = "1aaaf90fbafc50e7ba1e66ffceb00960"
10SRC_URI[sha256sum] = "21207d76c1031e517668898a6b46a9fb1501c7a4710ef5dfd6a40ad9e6757ea7"
11
12inherit pypi distutils3
13
14do_install_append() {
15 # Install as pip3 and leave pip2 as default
16 rm ${D}/${bindir}/pip
17}
18
19RDEPENDS_${PN} = "\
20 python3-compile \
21 python3-io \
22 python3-html \
23 python3-json \
24 python3-netserver \
25 python3-setuptools \
26 python3-unixadmin \
27 python3-xmlrpc \
28 python3-pickle \
29"
30
31BBCLASSEXTEND = "native nativesdk"