diff options
Diffstat (limited to 'meta/recipes-devtools/python/python3-numpy_2.2.2.bb')
-rw-r--r-- | meta/recipes-devtools/python/python3-numpy_2.2.2.bb | 72 |
1 files changed, 72 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python3-numpy_2.2.2.bb b/meta/recipes-devtools/python/python3-numpy_2.2.2.bb new file mode 100644 index 0000000000..3b74e9059d --- /dev/null +++ b/meta/recipes-devtools/python/python3-numpy_2.2.2.bb | |||
@@ -0,0 +1,72 @@ | |||
1 | SUMMARY = "A sophisticated Numeric Processing Package for Python" | ||
2 | HOMEPAGE = "https://numpy.org/" | ||
3 | DESCRIPTION = "NumPy is the fundamental package needed for scientific computing with Python." | ||
4 | SECTION = "devel/python" | ||
5 | LICENSE = "BSD-3-Clause & BSD-2-Clause & PSF-2.0 & Apache-2.0 & MIT" | ||
6 | LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=1de863c37a83e71b1e97b64d036ea78b" | ||
7 | |||
8 | SRCNAME = "numpy" | ||
9 | |||
10 | SRC_URI = "${GITHUB_BASE_URI}/download/v${PV}/${SRCNAME}-${PV}.tar.gz \ | ||
11 | file://0001-Don-t-search-usr-and-so-on-for-libraries-by-default-.patch \ | ||
12 | file://fix_reproducibility.patch \ | ||
13 | file://run-ptest \ | ||
14 | " | ||
15 | SRC_URI[sha256sum] = "ed6906f61834d687738d25988ae117683705636936cc605be0bb208b23df4d8f" | ||
16 | |||
17 | GITHUB_BASE_URI = "https://github.com/numpy/numpy/releases" | ||
18 | UPSTREAM_CHECK_REGEX = "releases/tag/v?(?P<pver>\d+(\.\d+)+)$" | ||
19 | |||
20 | inherit pkgconfig ptest python_mesonpy github-releases cython | ||
21 | |||
22 | S = "${WORKDIR}/numpy-${PV}" | ||
23 | |||
24 | PACKAGECONFIG[svml] = "-Ddisable-svml=false,-Ddisable-svml=true" | ||
25 | |||
26 | # Remove references to buildpaths from numpy's __config__.py | ||
27 | do_install:append() { | ||
28 | sed -i \ | ||
29 | -e 's|${S}=||g' \ | ||
30 | -e 's|${B}=||g' \ | ||
31 | -e 's|${RECIPE_SYSROOT_NATIVE}=||g' \ | ||
32 | -e 's|${RECIPE_SYSROOT_NATIVE}||g' \ | ||
33 | -e 's|${RECIPE_SYSROOT}=||g' \ | ||
34 | -e 's|${RECIPE_SYSROOT}||g' ${D}${PYTHON_SITEPACKAGES_DIR}/numpy/__config__.py | ||
35 | |||
36 | nativepython3 -mcompileall -s ${D} ${D}${PYTHON_SITEPACKAGES_DIR}/numpy/__config__.py | ||
37 | } | ||
38 | |||
39 | FILES:${PN}-staticdev += "${PYTHON_SITEPACKAGES_DIR}/numpy/_core/lib/*.a \ | ||
40 | ${PYTHON_SITEPACKAGES_DIR}/numpy/random/lib/*.a \ | ||
41 | " | ||
42 | |||
43 | # install what is needed for numpy.test() | ||
44 | RDEPENDS:${PN} = "python3-unittest \ | ||
45 | python3-difflib \ | ||
46 | python3-pprint \ | ||
47 | python3-pickle \ | ||
48 | python3-shell \ | ||
49 | python3-doctest \ | ||
50 | python3-datetime \ | ||
51 | python3-misc \ | ||
52 | python3-mmap \ | ||
53 | python3-netclient \ | ||
54 | python3-numbers \ | ||
55 | python3-pydoc \ | ||
56 | python3-pkgutil \ | ||
57 | python3-email \ | ||
58 | python3-compression \ | ||
59 | python3-ctypes \ | ||
60 | python3-threading \ | ||
61 | python3-multiprocessing \ | ||
62 | python3-json \ | ||
63 | " | ||
64 | RDEPENDS:${PN}-ptest += "python3-pytest \ | ||
65 | python3-hypothesis \ | ||
66 | python3-sortedcontainers \ | ||
67 | python3-resource \ | ||
68 | python3-typing-extensions \ | ||
69 | ldd \ | ||
70 | " | ||
71 | |||
72 | BBCLASSEXTEND = "native nativesdk" | ||