summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python3-native_3.5.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/python/python3-native_3.5.1.bb')
-rw-r--r--meta/recipes-devtools/python/python3-native_3.5.1.bb78
1 files changed, 78 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python3-native_3.5.1.bb b/meta/recipes-devtools/python/python3-native_3.5.1.bb
new file mode 100644
index 0000000000..152da1c5e2
--- /dev/null
+++ b/meta/recipes-devtools/python/python3-native_3.5.1.bb
@@ -0,0 +1,78 @@
1require recipes-devtools/python/python.inc
2
3PR = "${INC_PR}.0"
4PYTHON_MAJMIN = "3.5"
5DISTRO_SRC_URI ?= "file://sitecustomize.py"
6DISTRO_SRC_URI_linuxstdbase = ""
7SRC_URI = "http://www.python.org/ftp/python/${PV}/Python-${PV}.tar.xz \
8file://12-distutils-prefix-is-inside-staging-area.patch \
9file://python-config.patch \
10file://000-cross-compile.patch \
11file://020-dont-compile-python-files.patch \
12file://030-fixup-include-dirs.patch \
13file://070-dont-clean-ipkg-install.patch \
14file://080-distutils-dont_adjust_files.patch \
15file://110-enable-zlib.patch \
16file://130-readline-setup.patch \
17file://150-fix-setupterm.patch \
18file://python-3.3-multilib.patch \
19file://03-fix-tkinter-detection.patch \
20file://avoid_warning_about_tkinter.patch \
21file://shutil-follow-symlink-fix.patch \
22file://0001-h2py-Fix-issue-13032-where-it-fails-with-UnicodeDeco.patch \
23file://sysroot-include-headers.patch \
24file://unixccompiler.patch \
25${DISTRO_SRC_URI} \
26file://sysconfig.py-add-_PYTHON_PROJECT_SRC.patch \
27file://setup.py-check-cross_compiling-when-get-FLAGS.patch \
28"
29SRC_URI[md5sum] = "e9ea6f2623fffcdd871b7b19113fde80"
30SRC_URI[sha256sum] = "c6d57c0c366d9060ab6c0cdf889ebf3d92711d466cc0119c441dbf2746f725c9"
31
32LIC_FILES_CHKSUM = "file://LICENSE;md5=dd98d01d471fac8d8dbdd975229dba03"
33
34# exclude pre-releases for both python 2.x and 3.x
35UPSTREAM_CHECK_REGEX = "[Pp]ython-(?P<pver>\d+(\.\d+)+).tar"
36
37S = "${WORKDIR}/Python-${PV}"
38
39EXTRANATIVEPATH += "bzip2-native"
40DEPENDS = "openssl-native bzip2-replacement-native zlib-native readline-native sqlite3-native"
41
42inherit native
43
44RPROVIDES += "python3-distutils-native python3-compression-native python3-textutils-native python3-core-native"
45
46EXTRA_OECONF_append = " --bindir=${bindir}/${PN} --without-ensurepip"
47
48EXTRA_OEMAKE = '\
49 BUILD_SYS="" \
50 HOST_SYS="" \
51 LIBC="" \
52 STAGING_LIBDIR=${STAGING_LIBDIR_NATIVE} \
53 STAGING_INCDIR=${STAGING_INCDIR_NATIVE} \
54 LIB=${baselib} \
55 ARCH=${TARGET_ARCH} \
56'
57
58# No ctypes option for python 3
59PYTHONLSBOPTS = ""
60
61do_configure_append() {
62 autoreconf --verbose --install --force --exclude=autopoint ../Python-${PV}/Modules/_ctypes/libffi
63}
64
65do_install() {
66 install -d ${D}${libdir}/pkgconfig
67 oe_runmake 'DESTDIR=${D}' install
68 if [ -e ${WORKDIR}/sitecustomize.py ]; then
69 install -m 0644 ${WORKDIR}/sitecustomize.py ${D}/${libdir}/python${PYTHON_MAJMIN}
70 fi
71 install -d ${D}${bindir}/${PN}
72 install -m 0755 Parser/pgen ${D}${bindir}/${PN}
73
74 # Make sure we use /usr/bin/env python
75 for PYTHSCRIPT in `grep -rIl ${bindir}/${PN}/python ${D}${bindir}/${PN}`; do
76 sed -i -e '1s|^#!.*|#!/usr/bin/env python3|' $PYTHSCRIPT
77 done
78}