summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python3-native_3.3.3.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/python/python3-native_3.3.3.bb')
-rw-r--r--meta/recipes-devtools/python/python3-native_3.3.3.bb70
1 files changed, 70 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python3-native_3.3.3.bb b/meta/recipes-devtools/python/python3-native_3.3.3.bb
new file mode 100644
index 0000000000..26b811fc5c
--- /dev/null
+++ b/meta/recipes-devtools/python/python3-native_3.3.3.bb
@@ -0,0 +1,70 @@
1require recipes-devtools/python/python.inc
2
3PR = "${INC_PR}.0"
4PYTHON_MAJMIN = "3.3"
5DISTRO_SRC_URI ?= "file://sitecustomize.py"
6DISTRO_SRC_URI_linuxstdbase = ""
7SRC_URI = "http://www.python.org/ftp/python/${PV}/Python-${PV}.tar.bz2 \
8file://12-distutils-prefix-is-inside-staging-area.patch \
9file://000-cross-compile.patch \
10file://020-dont-compile-python-files.patch \
11file://030-fixup-include-dirs.patch \
12file://070-dont-clean-ipkg-install.patch \
13file://080-distutils-dont_adjust_files.patch \
14file://110-enable-zlib.patch \
15file://130-readline-setup.patch \
16file://150-fix-setupterm.patch \
17file://python-3.3-multilib.patch \
18file://03-fix-tkinter-detection.patch \
19file://avoid_warning_about_tkinter.patch \
20file://06-ctypes-libffi-fix-configure.patch \
21file://shutil-follow-symlink-fix.patch \
22file://0001-h2py-Fix-issue-13032-where-it-fails-with-UnicodeDeco.patch \
23file://sysroot-include-headers.patch \
24file://unixccompiler.patch \
25${DISTRO_SRC_URI} \
26"
27SRC_URI[md5sum] = "f3ebe34d4d8695bf889279b54673e10c"
28SRC_URI[sha256sum] = "e526e9b612f623888364d30cc9f3dfc34dcef39065c713bdbcddf47df84d8dcb"
29
30LIC_FILES_CHKSUM = "file://LICENSE;md5=4eaea08eaaf6875189b0c49f26fa2005"
31
32S = "${WORKDIR}/Python-${PV}"
33
34EXTRANATIVEPATH += "bzip2-native"
35DEPENDS = "openssl-native bzip2-replacement-native zlib-native readline-native sqlite3-native"
36
37inherit native
38
39RPROVIDES += "python3-distutils-native python3-compression-native python3-textutils-native python3-core-native"
40
41EXTRA_OECONF_append = " --bindir=${bindir}/${PN}"
42
43EXTRA_OEMAKE = '\
44 BUILD_SYS="" \
45 HOST_SYS="" \
46 LIBC="" \
47 STAGING_LIBDIR=${STAGING_LIBDIR_NATIVE} \
48 STAGING_INCDIR=${STAGING_INCDIR_NATIVE} \
49 LIB=${baselib} \
50 ARCH=${TARGET_ARCH} \
51'
52
53do_configure_prepend() {
54 autoreconf --verbose --install --force --exclude=autopoint Modules/_ctypes/libffi || bbnote "_ctypes failed to autoreconf"
55}
56
57do_install() {
58 install -d ${D}${libdir}/pkgconfig
59 oe_runmake 'DESTDIR=${D}' install
60 if [ -e ${WORKDIR}/sitecustomize.py ]; then
61 install -m 0644 ${WORKDIR}/sitecustomize.py ${D}/${libdir}/python${PYTHON_MAJMIN}
62 fi
63 install -d ${D}${bindir}/${PN}
64 install -m 0755 Parser/pgen ${D}${bindir}/${PN}
65
66 # Make sure we use /usr/bin/env python
67 for PYTHSCRIPT in `grep -rIl ${bindir}/${PN}/python ${D}${bindir}/${PN}`; do
68 sed -i -e '1s|^#!.*|#!/usr/bin/env python|' $PYTHSCRIPT
69 done
70}