summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python3-native_3.3.3.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/python/python3-native_3.3.3.bb')
-rw-r--r--meta/recipes-devtools/python/python3-native_3.3.3.bb77
1 files changed, 77 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python3-native_3.3.3.bb b/meta/recipes-devtools/python/python3-native_3.3.3.bb
new file mode 100644
index 0000000000..9ae2a0b373
--- /dev/null
+++ b/meta/recipes-devtools/python/python3-native_3.3.3.bb
@@ -0,0 +1,77 @@
1require recipes-devtools/python/python.inc
2
3PR = "${INC_PR}.0"
4PYTHON_MAJMIN = "3.3"
5DISTRO_SRC_URI ?= "file://sitecustomize.py"
6DISTRO_SRC_URI_linuxstdbase = ""
7SRC_URI = "http://www.python.org/ftp/python/${PV}/Python-${PV}.tar.bz2 \
8file://12-distutils-prefix-is-inside-staging-area.patch \
9file://python-config.patch \
10file://000-cross-compile.patch \
11file://020-dont-compile-python-files.patch \
12file://030-fixup-include-dirs.patch \
13file://070-dont-clean-ipkg-install.patch \
14file://080-distutils-dont_adjust_files.patch \
15file://110-enable-zlib.patch \
16file://130-readline-setup.patch \
17file://150-fix-setupterm.patch \
18file://python-3.3-multilib.patch \
19file://03-fix-tkinter-detection.patch \
20file://avoid_warning_about_tkinter.patch \
21file://06-ctypes-libffi-fix-configure.patch \
22file://shutil-follow-symlink-fix.patch \
23file://0001-h2py-Fix-issue-13032-where-it-fails-with-UnicodeDeco.patch \
24file://sysroot-include-headers.patch \
25file://unixccompiler.patch \
26file://fix-ast.h-dependency.patch \
27file://makerace.patch \
28${DISTRO_SRC_URI} \
29file://python3-fix-build-error-with-Readline-6.3.patch \
30"
31SRC_URI[md5sum] = "f3ebe34d4d8695bf889279b54673e10c"
32SRC_URI[sha256sum] = "e526e9b612f623888364d30cc9f3dfc34dcef39065c713bdbcddf47df84d8dcb"
33
34LIC_FILES_CHKSUM = "file://LICENSE;md5=4eaea08eaaf6875189b0c49f26fa2005"
35
36S = "${WORKDIR}/Python-${PV}"
37
38EXTRANATIVEPATH += "bzip2-native"
39DEPENDS = "openssl-native bzip2-replacement-native zlib-native readline-native sqlite3-native"
40
41inherit native
42
43RPROVIDES += "python3-distutils-native python3-compression-native python3-textutils-native python3-core-native"
44
45EXTRA_OECONF_append = " --bindir=${bindir}/${PN}"
46
47EXTRA_OEMAKE = '\
48 BUILD_SYS="" \
49 HOST_SYS="" \
50 LIBC="" \
51 STAGING_LIBDIR=${STAGING_LIBDIR_NATIVE} \
52 STAGING_INCDIR=${STAGING_INCDIR_NATIVE} \
53 LIB=${baselib} \
54 ARCH=${TARGET_ARCH} \
55'
56
57# No ctypes option for python 3
58PYTHONLSBOPTS = ""
59
60do_configure_prepend() {
61 autoreconf --verbose --install --force --exclude=autopoint Modules/_ctypes/libffi || bbnote "_ctypes failed to autoreconf"
62}
63
64do_install() {
65 install -d ${D}${libdir}/pkgconfig
66 oe_runmake 'DESTDIR=${D}' install
67 if [ -e ${WORKDIR}/sitecustomize.py ]; then
68 install -m 0644 ${WORKDIR}/sitecustomize.py ${D}/${libdir}/python${PYTHON_MAJMIN}
69 fi
70 install -d ${D}${bindir}/${PN}
71 install -m 0755 Parser/pgen ${D}${bindir}/${PN}
72
73 # Make sure we use /usr/bin/env python
74 for PYTHSCRIPT in `grep -rIl ${bindir}/${PN}/python ${D}${bindir}/${PN}`; do
75 sed -i -e '1s|^#!.*|#!/usr/bin/env python3|' $PYTHSCRIPT
76 done
77}