summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python3-markupsafe_1.1.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/python/python3-markupsafe_1.1.1.bb')
-rw-r--r--meta/recipes-devtools/python/python3-markupsafe_1.1.1.bb28
1 files changed, 28 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python3-markupsafe_1.1.1.bb b/meta/recipes-devtools/python/python3-markupsafe_1.1.1.bb
new file mode 100644
index 0000000000..403a98a43f
--- /dev/null
+++ b/meta/recipes-devtools/python/python3-markupsafe_1.1.1.bb
@@ -0,0 +1,28 @@
1DESCRIPTION = "Implements a XML/HTML/XHTML Markup safe string for Python"
2HOMEPAGE = "http://github.com/mitsuhiko/markupsafe"
3LICENSE = "BSD-3-Clause"
4LIC_FILES_CHKSUM = "file://LICENSE.rst;md5=ffeffa59c90c9c4a033c7574f8f3fb75"
5
6SRC_URI[md5sum] = "43fd756864fe42063068e092e220c57b"
7SRC_URI[sha256sum] = "29872e92839765e546828bb7754a68c418d927cd064fd4708fab9fe9c8bb116b"
8
9PYPI_PACKAGE = "MarkupSafe"
10inherit pypi setuptools3
11# ptest disabled in OE-Core for now due to missing dependencies
12
13RDEPENDS_${PN} += "${PYTHON_PN}-stringold"
14
15BBCLASSEXTEND = "native nativesdk"
16
17SRC_URI += " \
18 file://run-ptest \
19"
20
21RDEPENDS_${PN}-ptest += " \
22 ${PYTHON_PN}-pytest \
23"
24
25do_install_ptest() {
26 install -d ${D}${PTEST_PATH}/tests
27 cp -f ${S}/tests/* ${D}${PTEST_PATH}/tests/
28}