summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python3-jinja2_2.11.3.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/python/python3-jinja2_2.11.3.bb')
-rw-r--r--meta/recipes-devtools/python/python3-jinja2_2.11.3.bb48
1 files changed, 48 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python3-jinja2_2.11.3.bb b/meta/recipes-devtools/python/python3-jinja2_2.11.3.bb
new file mode 100644
index 0000000000..9f054c6024
--- /dev/null
+++ b/meta/recipes-devtools/python/python3-jinja2_2.11.3.bb
@@ -0,0 +1,48 @@
1DESCRIPTION = "Python Jinja2: A small but fast and easy to use stand-alone template engine written in pure python."
2HOMEPAGE = "https://pypi.org/project/Jinja2/"
3
4LICENSE = "BSD-3-Clause"
5LIC_FILES_CHKSUM = "file://LICENSE.rst;md5=5dc88300786f1c214c1e9827a5229462"
6
7SRC_URI[sha256sum] = "a6d58433de0ae800347cab1fa3043cebbabe8baa9d29e668f1c768cb87a333c6"
8
9PYPI_PACKAGE = "Jinja2"
10
11CVE_PRODUCT = "jinja2 jinja"
12
13CLEANBROKEN = "1"
14
15inherit pypi setuptools3
16# ptest disabled in OE-Core for now due to missing dependencies
17
18
19SRC_URI += " \
20 file://run-ptest \
21"
22
23do_install_ptest() {
24 install -d ${D}${PTEST_PATH}/tests
25 cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
26}
27
28RDEPENDS_${PN}-ptest += " \
29 ${PYTHON_PN}-pytest \
30 ${PYTHON_PN}-unixadmin \
31"
32
33RDEPENDS_${PN} += " \
34 ${PYTHON_PN}-asyncio \
35 ${PYTHON_PN}-crypt \
36 ${PYTHON_PN}-io \
37 ${PYTHON_PN}-json \
38 ${PYTHON_PN}-markupsafe \
39 ${PYTHON_PN}-math \
40 ${PYTHON_PN}-netclient \
41 ${PYTHON_PN}-numbers\
42 ${PYTHON_PN}-pickle \
43 ${PYTHON_PN}-pprint \
44 ${PYTHON_PN}-shell \
45 ${PYTHON_PN}-threading \
46"
47
48BBCLASSEXTEND = "native nativesdk"