summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python3-dtschema_2024.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/python/python3-dtschema_2024.2.bb')
-rw-r--r--meta/recipes-devtools/python/python3-dtschema_2024.2.bb20
1 files changed, 20 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python3-dtschema_2024.2.bb b/meta/recipes-devtools/python/python3-dtschema_2024.2.bb
new file mode 100644
index 0000000000..0e911dfb3d
--- /dev/null
+++ b/meta/recipes-devtools/python/python3-dtschema_2024.2.bb
@@ -0,0 +1,20 @@
1SUMMARY = "Tooling for devicetree validation using YAML and jsonschema"
2HOMEPAGE = "https://github.com/devicetree-org/dt-schema"
3LICENSE = "BSD-2-Clause"
4LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=457495c8fa03540db4a576bf7869e811"
5
6inherit pypi python_setuptools_build_meta
7
8PYPI_PACKAGE = "dtschema"
9
10SRC_URI[sha256sum] = "df4e5afb35bda93894209d2465e87fb7103f1a95a05909ebcb594fc4cf4fdd1e"
11
12DEPENDS += "python3-setuptools-scm-native"
13RDEPENDS:${PN} += "\
14 python3-dtc \
15 python3-jsonschema \
16 python3-rfc3987 \
17 python3-ruamel-yaml \
18 "
19
20BBCLASSEXTEND = "native nativesdk"