summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python3-dtschema_2022.8.3.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/python/python3-dtschema_2022.8.3.bb')
-rw-r--r--meta/recipes-devtools/python/python3-dtschema_2022.8.3.bb15
1 files changed, 15 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python3-dtschema_2022.8.3.bb b/meta/recipes-devtools/python/python3-dtschema_2022.8.3.bb
new file mode 100644
index 0000000000..bc819c0dd6
--- /dev/null
+++ b/meta/recipes-devtools/python/python3-dtschema_2022.8.3.bb
@@ -0,0 +1,15 @@
1DESCRIPTION = "Tooling for devicetree validation using YAML and jsonschema"
2HOMEPAGE = "https://github.com/devicetree-org/dt-schema"
3LICENSE = "BSD-2-Clause"
4LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=457495c8fa03540db4a576bf7869e811"
5
6inherit pypi setuptools3
7
8PYPI_PACKAGE = "dtschema"
9
10SRC_URI[sha256sum] = "128c88a393cd04154cef4d4b10a643e4473ae290b436e8e61d2e97ae8e53255d"
11
12DEPENDS += "python3-setuptools-scm-native"
13RDEPENDS:${PN} += "python3-ruamel-yaml python3-jsonschema python3-rfc3987"
14
15BBCLASSEXTEND = "native nativesdk"