summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python3-dbus_1.2.4.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/python/python3-dbus_1.2.4.bb')
-rw-r--r--meta/recipes-devtools/python/python3-dbus_1.2.4.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python3-dbus_1.2.4.bb b/meta/recipes-devtools/python/python3-dbus_1.2.4.bb
new file mode 100644
index 0000000000..c058cafcf1
--- /dev/null
+++ b/meta/recipes-devtools/python/python3-dbus_1.2.4.bb
@@ -0,0 +1,27 @@
1SUMMARY = "Python bindings for the DBus inter-process communication system"
2SECTION = "devel/python"
3HOMEPAGE = "http://www.freedesktop.org/Software/dbus"
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://COPYING;md5=0b83047ce9e948b67c0facc5f233476a"
6DEPENDS = "expat dbus dbus-glib virtual/libintl"
7
8SRC_URI = "http://dbus.freedesktop.org/releases/dbus-python/dbus-python-${PV}.tar.gz \
9"
10
11SRC_URI[md5sum] = "7372a588c83a7232b4e08159bfd48fe5"
12SRC_URI[sha256sum] = "e2f1d6871f74fba23652e51d10873e54f71adab0525833c19bad9e99b1b2f9cc"
13S = "${WORKDIR}/dbus-python-${PV}"
14
15inherit distutils3-base autotools pkgconfig
16
17PACKAGECONFIG ?= ""
18PACKAGECONFIG[docs] = "--enable-html-docs,--disable-html-docs,python-docutils-native"
19PACKAGECONFIG[api-docs] = "--enable-api-docs,--disable-api-docs,python-docutils-native python-epydoc-native"
20
21do_configure_prepend() {
22 export PYTHON=${PYTHON}
23}
24
25RDEPENDS_${PN} = "python3-io python3-logging python3-stringold python3-threading python3-xml"
26
27FILES_${PN}-dev += "${libdir}/pkgconfig"