summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python3-dbus_1.2.12.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/python/python3-dbus_1.2.12.bb')
-rw-r--r--meta/recipes-devtools/python/python3-dbus_1.2.12.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python3-dbus_1.2.12.bb b/meta/recipes-devtools/python/python3-dbus_1.2.12.bb
new file mode 100644
index 0000000000..d005dc4a90
--- /dev/null
+++ b/meta/recipes-devtools/python/python3-dbus_1.2.12.bb
@@ -0,0 +1,26 @@
1SUMMARY = "Python bindings for the DBus inter-process communication system"
2SECTION = "devel/python"
3HOMEPAGE = "http://www.freedesktop.org/Software/dbus"
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://COPYING;md5=b03240518994df6d8c974675675e5ca4"
6DEPENDS = "expat dbus glib-2.0 virtual/libintl"
7
8SRC_URI = "http://dbus.freedesktop.org/releases/dbus-python/dbus-python-${PV}.tar.gz"
9
10SRC_URI[md5sum] = "428b7a9e7e2d154a7ceb3e13536283e4"
11SRC_URI[sha256sum] = "cdd4de2c4f5e58f287b12013ed7b41dee81d503c8d0d2397c5bd2fb01badf260"
12
13S = "${WORKDIR}/dbus-python-${PV}"
14
15inherit distutils3-base autotools pkgconfig
16
17# documentation needs python3-sphinx, which is not in oe-core or meta-python for now
18# change to use PACKAGECONFIG when python3-sphinx is added to oe-core
19EXTRA_OECONF += "--disable-documentation"
20
21
22RDEPENDS_${PN} = "python3-io python3-logging python3-stringold python3-threading python3-xml"
23
24FILES_${PN}-dev += "${libdir}/pkgconfig"
25
26BBCLASSEXTEND = "native nativesdk"