summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python3-attrs_23.1.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/python/python3-attrs_23.1.0.bb')
-rw-r--r--meta/recipes-devtools/python/python3-attrs_23.1.0.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python3-attrs_23.1.0.bb b/meta/recipes-devtools/python/python3-attrs_23.1.0.bb
new file mode 100644
index 0000000000..c8e2e514a4
--- /dev/null
+++ b/meta/recipes-devtools/python/python3-attrs_23.1.0.bb
@@ -0,0 +1,24 @@
1SUMMARY = "Classes Without Boilerplate"
2HOMEPAGE = "http://www.attrs.org/"
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=5e55731824cf9205cfabeab9a0600887"
5
6SRC_URI[sha256sum] = "6279836d581513a26f1bf235f9acd333bc9115683f14f7e8fae46c98fc50e015"
7
8inherit pypi python_hatchling
9
10DEPENDS += " \
11 ${PYTHON_PN}-hatch-vcs-native \
12 ${PYTHON_PN}-hatch-fancy-pypi-readme-native \
13"
14
15RDEPENDS:${PN}:class-target += " \
16 ${PYTHON_PN}-crypt \
17 ${PYTHON_PN}-ctypes \
18"
19RDEPENDS:${PN}:class-nativesdk += " \
20 ${PYTHON_PN}-crypt \
21 ${PYTHON_PN}-ctypes \
22"
23
24BBCLASSEXTEND = "native nativesdk"