summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python-smartpm_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/python/python-smartpm_git.bb')
-rw-r--r--meta/recipes-devtools/python/python-smartpm_git.bb36
1 files changed, 18 insertions, 18 deletions
diff --git a/meta/recipes-devtools/python/python-smartpm_git.bb b/meta/recipes-devtools/python/python-smartpm_git.bb
index 668d171a58..0c260482df 100644
--- a/meta/recipes-devtools/python/python-smartpm_git.bb
+++ b/meta/recipes-devtools/python/python-smartpm_git.bb
@@ -56,41 +56,41 @@ inherit distutils
56 56
57do_install_append() { 57do_install_append() {
58 # We don't support the following items 58 # We don't support the following items
59 rm -rf ${D}${libdir}/python*/site-packages/smart/backends/slack 59 rm -rf ${D}${PYTHON_SITEPACKAGES_DIR}/smart/backends/slack
60 rm -rf ${D}${libdir}/python*/site-packages/smart/backends/arch 60 rm -rf ${D}${PYTHON_SITEPACKAGES_DIR}/smart/backends/arch
61 rm -rf ${D}${libdir}/python*/site-packages/smart/interfaces/qt 61 rm -rf ${D}${PYTHON_SITEPACKAGES_DIR}/smart/interfaces/qt
62 62
63 # Temporary, debian support in OE is missing the python module 63 # Temporary, debian support in OE is missing the python module
64 rm -f ${D}${libdir}/python*/site-packages/smart/plugins/aptchannelsync.py* 64 rm -f ${D}${PYTHON_SITEPACKAGES_DIR}/smart/plugins/aptchannelsync.py*
65 rm -f ${D}${libdir}/python*/site-packages/smart/plugins/debdir.py* 65 rm -f ${D}${PYTHON_SITEPACKAGES_DIR}/smart/plugins/debdir.py*
66 rm -rf ${D}${libdir}/python*/site-packages/smart/backends/deb 66 rm -rf ${D}${PYTHON_SITEPACKAGES_DIR}/smart/backends/deb
67 67
68 # Disable automatic channel detection 68 # Disable automatic channel detection
69 rm -f ${D}${libdir}/python*/site-packages/smart/plugins/detectsys.py* 69 rm -f ${D}${PYTHON_SITEPACKAGES_DIR}/smart/plugins/detectsys.py*
70 70
71 # Disable landscape support 71 # Disable landscape support
72 rm -f ${D}${libdir}/python*/site-packages/smart/plugins/landscape.py* 72 rm -f ${D}${PYTHON_SITEPACKAGES_DIR}/smart/plugins/landscape.py*
73 73
74 # Disable urpmi channel support 74 # Disable urpmi channel support
75 rm -f ${D}${libdir}/python*/site-packages/smart/plugins/urpmichannelsync.py* 75 rm -f ${D}${PYTHON_SITEPACKAGES_DIR}/smart/plugins/urpmichannelsync.py*
76 76
77 # Disable yum channel support 77 # Disable yum channel support
78 rm -f ${D}${libdir}/python*/site-packages/smart/plugins/yumchannelsync.py* 78 rm -f ${D}${PYTHON_SITEPACKAGES_DIR}/smart/plugins/yumchannelsync.py*
79 79
80 # Disable zypper channel support 80 # Disable zypper channel support
81 rm -f ${D}${libdir}/python*/site-packages/smart/plugins/zyppchannelsync.py* 81 rm -f ${D}${PYTHON_SITEPACKAGES_DIR}/smart/plugins/zyppchannelsync.py*
82 82
83 if [ -z "${@bb.utils.contains('PACKAGECONFIG', 'rpm', 'rpm', '', d)}" ]; then 83 if [ -z "${@bb.utils.contains('PACKAGECONFIG', 'rpm', 'rpm', '', d)}" ]; then
84 rm -f ${D}${libdir}/python*/site-packages/smart/plugins/rpmdir.py* 84 rm -f ${D}${PYTHON_SITEPACKAGES_DIR}/smart/plugins/rpmdir.py*
85 rm -rf ${D}${libdir}/python*/site-packages/smart/backends/rpm 85 rm -rf ${D}${PYTHON_SITEPACKAGES_DIR}/smart/backends/rpm
86 fi 86 fi
87 87
88 if [ -z "${@bb.utils.contains('PACKAGECONFIG', 'qt4', 'qt4', '', d)}" ]; then 88 if [ -z "${@bb.utils.contains('PACKAGECONFIG', 'qt4', 'qt4', '', d)}" ]; then
89 rm -rf ${D}${libdir}/python*/site-packages/smart/interfaces/qt4 89 rm -rf ${D}${PYTHON_SITEPACKAGES_DIR}/smart/interfaces/qt4
90 fi 90 fi
91 91
92 if [ -z "${@bb.utils.contains('PACKAGECONFIG', 'gtk+', 'gtk', '', d)}" ]; then 92 if [ -z "${@bb.utils.contains('PACKAGECONFIG', 'gtk+', 'gtk', '', d)}" ]; then
93 rm -rf ${D}${libdir}/python*/site-packages/smart/interfaces/gtk 93 rm -rf ${D}${PYTHON_SITEPACKAGES_DIR}/smart/interfaces/gtk
94 fi 94 fi
95} 95}
96 96
@@ -130,10 +130,10 @@ RDEPENDS_${PN}-interface-gtk = "gtk+ ${PN}-interface-images"
130 130
131FILES_smartpm = "${bindir}/smart" 131FILES_smartpm = "${bindir}/smart"
132 132
133FILES_${PN}-backend-rpm = "${libdir}/python*/site-packages/smart/backends/rpm" 133FILES_${PN}-backend-rpm = "${PYTHON_SITEPACKAGES_DIR}/smart/backends/rpm"
134 134
135FILES_${PN}-interface-qt4 = "${libdir}/python*/site-packages/smart/interfaces/qt4" 135FILES_${PN}-interface-qt4 = "${PYTHON_SITEPACKAGES_DIR}/smart/interfaces/qt4"
136FILES_${PN}-interface-gtk = "${libdir}/python*/site-packages/smart/interfaces/gtk" 136FILES_${PN}-interface-gtk = "${PYTHON_SITEPACKAGES_DIR}/smart/interfaces/gtk"
137FILES_${PN}-interface-images = "${datadir}/${baselib}/python*/site-packages/smart/interfaces/images" 137FILES_${PN}-interface-images = "${datadir}/${baselib}/python*/site-packages/smart/interfaces/images"
138 138
139BBCLASSEXTEND = "native nativesdk" 139BBCLASSEXTEND = "native nativesdk"