summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python-smartpm_1.4.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/python/python-smartpm_1.4.1.bb')
-rw-r--r--meta/recipes-devtools/python/python-smartpm_1.4.1.bb17
1 files changed, 16 insertions, 1 deletions
diff --git a/meta/recipes-devtools/python/python-smartpm_1.4.1.bb b/meta/recipes-devtools/python/python-smartpm_1.4.1.bb
index 53f232bfab..04f61f8999 100644
--- a/meta/recipes-devtools/python/python-smartpm_1.4.1.bb
+++ b/meta/recipes-devtools/python/python-smartpm_1.4.1.bb
@@ -11,7 +11,7 @@ LICENSE = "GPLv2"
11LIC_FILES_CHKSUM = "file://LICENSE;md5=393a5ca445f6965873eca0259a17f833" 11LIC_FILES_CHKSUM = "file://LICENSE;md5=393a5ca445f6965873eca0259a17f833"
12 12
13DEPENDS = "python rpm" 13DEPENDS = "python rpm"
14PR = "r4" 14PR = "r5"
15SRCNAME = "smart" 15SRCNAME = "smart"
16 16
17SRC_URI = "\ 17SRC_URI = "\
@@ -87,6 +87,21 @@ do_install_append() {
87 fi 87 fi
88} 88}
89 89
90add_native_wrapper() {
91 create_wrapper ${D}/${bindir}/smart \
92 RPM_USRLIBRPM='`dirname $''realpath`'/${@os.path.relpath(d.getVar('libdir', True), d.getVar('bindir', True))}/rpm \
93 RPM_ETCRPM='$'{RPM_ETCRPM-'`dirname $''realpath`'/${@os.path.relpath(d.getVar('sysconfdir', True), d.getVar('bindir', True))}/rpm} \
94 RPM_LOCALEDIRRPM='`dirname $''realpath`'/${@os.path.relpath(d.getVar('datadir', True), d.getVar('bindir', True))}/locale
95}
96
97do_install_append_class-native() {
98 add_native_wrapper
99}
100
101do_install_append_class-nativesdk() {
102 add_native_wrapper
103}
104
90PACKAGES = "${PN}-dev ${PN}-dbg ${PN}-doc smartpm \ 105PACKAGES = "${PN}-dev ${PN}-dbg ${PN}-doc smartpm \
91 ${@base_contains('PACKAGECONFIG', 'rpm', '${PN}-backend-rpm', '', d)} \ 106 ${@base_contains('PACKAGECONFIG', 'rpm', '${PN}-backend-rpm', '', d)} \
92 ${@base_contains('PACKAGECONFIG', 'qt4', '${PN}-interface-qt4', '', d)} \ 107 ${@base_contains('PACKAGECONFIG', 'qt4', '${PN}-interface-qt4', '', d)} \