summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python-smartpm_1.4.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/python/python-smartpm_1.4.1.bb')
-rw-r--r--meta/recipes-devtools/python/python-smartpm_1.4.1.bb119
1 files changed, 119 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python-smartpm_1.4.1.bb b/meta/recipes-devtools/python/python-smartpm_1.4.1.bb
new file mode 100644
index 0000000000..bc0c1f9941
--- /dev/null
+++ b/meta/recipes-devtools/python/python-smartpm_1.4.1.bb
@@ -0,0 +1,119 @@
1SUMMARY = "The Smart Package Manager"
2
3DESCRIPTION = "The Smart Package Manager project has the ambitious objective of creating \
4smart and portable algorithms for solving adequately the problem of managing software \
5upgrades and installation. This tool works in all major distributions and will bring \
6notable advantages over native tools currently in use (APT, APT-RPM, YUM, URPMI, etc)."
7
8HOMEPAGE = "http://smartpm.org/"
9SECTION = "devel/python"
10LICENSE = "GPLv2"
11LIC_FILES_CHKSUM = "file://LICENSE;md5=393a5ca445f6965873eca0259a17f833"
12
13DEPENDS = "python rpm"
14PR = "r0"
15SRCNAME = "smart"
16
17SRC_URI = "\
18 http://launchpad.net/smart/trunk/${PV}/+download/${SRCNAME}-${PV}.tar.bz2 \
19 file://smartpm-rpm5-nodig.patch \
20 file://smart-rpm-root.patch \
21 "
22
23SRC_URI[md5sum] = "573ef32ba177a6b3c4bf7ef04873fcb6"
24SRC_URI[sha256sum] = "b1d519ddb43d60f293b065c28870a5d9e8b591cd49e8c68caea48ace91085eba"
25S = "${WORKDIR}/${SRCNAME}-${PV}"
26
27# Options - rpm, qt4, gtk
28PACKAGECONFIG ??= "rpm"
29
30RPM_RDEP = "python-smartpm-backend-rpm"
31QT_RDEP = "python-smartpm-interface-qt4"
32GTK_RDEP = "python-smartpm-interface-gtk"
33
34RPM_RDEP_virtclass-native = ""
35QT_RDEP_virtclass-native = ""
36GTK_RDEP_virtclass-native = ""
37
38PACKAGECONFIG[rpm] = ",,rpm,${RPM_RDEP}"
39PACKAGECONFIG[qt4] = ",,qt4-x11,${QT_RDEP}"
40PACKAGECONFIG[gtk] = ",,gtk+,${GTK_RDEP}"
41
42inherit distutils
43
44do_install_append() {
45 # Cleanup unused item...
46 rmdir ${D}${datadir}/share
47
48 # We don't support the following items
49 rm -rf ${D}${libdir}/python*/site-packages/smart/backends/slack
50 rm -rf ${D}${libdir}/python*/site-packages/smart/backends/arch
51 rm -rf ${D}${libdir}/python*/site-packages/smart/interfaces/qt
52
53 # Temporary, debian support in OE is missing the python module
54 rm -f ${D}${libdir}/python*/site-packages/smart/plugins/aptchannelsync.py*
55 rm -f ${D}${libdir}/python*/site-packages/smart/plugins/debdir.py*
56 rm -rf ${D}${libdir}/python*/site-packages/smart/backends/deb
57
58 # Disable automatic channel detection
59 rm -f ${D}${libdir}/python*/site-packages/smart/plugins/detectsys.py*
60
61 # Disable landscape support
62 rm -f ${D}${libdir}/python*/site-packages/smart/plugins/landscape.py*
63
64 # Disable urpmi channel support
65 rm -f ${D}${libdir}/python*/site-packages/smart/plugins/urpmichannelsync.py*
66
67 # Disable yum channel support
68 rm -f ${D}${libdir}/python*/site-packages/smart/plugins/yumchannelsync.py*
69
70 # Disable zypper channel support
71 rm -f ${D}${libdir}/python*/site-packages/smart/plugins/zyppchannelsync.py*
72
73 if [ -z "${@base_contains('PACKAGECONFIG', 'rpm', 'rpm', '', d)}" ]; then
74 rm -f ${D}${libdir}/python*/site-packages/smart/plugins/rpmdir.py*
75 rm -rf ${D}${libdir}/python*/site-packages/smart/backends/rpm
76 fi
77
78 if [ -z "${@base_contains('PACKAGECONFIG', 'qt4', 'qt4', '', d)}" ]; then
79 rm -rf ${D}${libdir}/python*/site-packages/smart/interfaces/qt4
80 fi
81
82 if [ -z "${@base_contains('PACKAGECONFIG', 'gtk+', 'gtk', '', d)}" ]; then
83 rm -rf ${D}${libdir}/python*/site-packages/smart/interfaces/gtk
84 fi
85}
86
87PACKAGES = "python-smartpm-dev python-smartpm-dbg python-smartpm-doc smartpm"
88PACKAGES += "${@base_contains('PACKAGECONFIG', 'rpm', 'python-smartpm-backend-rpm', '', d)}"
89PACKAGES += "${@base_contains('PACKAGECONFIG', 'qt4', 'python-smartpm-interface-qt4', '', d)}"
90PACKAGES += "${@base_contains('PACKAGECONFIG', 'gtk', 'python-smartpm-interface-gtk', '', d)}"
91PACKAGES += "python-smartpm-interface-images"
92PACKAGES += "python-smartpm"
93
94RDEPENDS_smartpm = 'python-smartpm'
95
96RDEPENDS_python-smartpm_append = " virtual/python-smartpm-backend python-codecs python-textutils python-xml"
97RDEPENDS_python-smartpm_append += " python-fcntl python-pickle python-crypt python-compression python-shell"
98RDEPENDS_python-smartpm_append += " python-resource python-netclient python-threading python-unixadmin"
99
100#RDEPENDS_python-smartpm_append += " python-modules"
101
102RDEPENDS_python-smartpm-backend-rpm = 'python-rpm'
103RPROVIDES_python-smartpm-backend-rpm = 'virtual/python-smartpm-backend'
104
105RDEPENDS_python-smartpm-interface-qt4 = 'qt4-x11 python-smartpm-interface-images'
106RDEPENDS_python-smartpm-interface-gtk = 'gtk+ python-smartpm-interface-images'
107
108FILES_smartpm = "${bindir}/smart"
109
110FILES_${PN}-dbg += "${libdir}/python*/site-packages/smart/backends/rpm/.debug"
111
112FILES_python-smartpm-backend-rpm = "${libdir}/python*/site-packages/smart/backends/rpm"
113
114FILES_python-smartpm-interface-qt4 = "${libdir}/python*/site-packages/smart/interfaces/qt4"
115FILES_python-smartpm-interface-gtk = "${libdir}/python*/site-packages/smart/interfaces/gtk"
116FILES_python-smartpm-interface-images = "${datadir}/${baselib}/python*/site-packages/smart/interfaces/images"
117
118BBCLASSEXTEND = "native"
119