summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python-setuptools_19.4.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/python/python-setuptools_19.4.bb')
-rw-r--r--meta/recipes-devtools/python/python-setuptools_19.4.bb37
1 files changed, 37 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python-setuptools_19.4.bb b/meta/recipes-devtools/python/python-setuptools_19.4.bb
new file mode 100644
index 0000000000..86bbebf081
--- /dev/null
+++ b/meta/recipes-devtools/python/python-setuptools_19.4.bb
@@ -0,0 +1,37 @@
1require python-setuptools.inc
2
3PROVIDES = "python-distribute"
4
5DEPENDS += "python"
6DEPENDS_class-native += "python-native"
7
8inherit distutils
9
10DISTUTILS_INSTALL_ARGS += "--install-lib=${D}${libdir}/${PYTHON_DIR}/site-packages"
11
12RDEPENDS_${PN} = "\
13 python-stringold \
14 python-email \
15 python-shell \
16 python-distutils \
17 python-compression \
18 python-pkgutil \
19 python-plistlib \
20 python-numbers \
21 python-html \
22 python-netserver \
23 python-ctypes \
24 python-subprocess \
25 python-unittest \
26"
27
28RDEPENDS_${PN}_class-native = "\
29 python-distutils \
30 python-compression \
31"
32
33RREPLACES_${PN} = "python-distribute"
34RPROVIDES_${PN} = "python-distribute"
35RCONFLICTS_${PN} = "python-distribute"
36
37BBCLASSEXTEND = "native nativesdk"