summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python-setuptools_18.7.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/python/python-setuptools_18.7.1.bb')
-rw-r--r--meta/recipes-devtools/python/python-setuptools_18.7.1.bb47
1 files changed, 47 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python-setuptools_18.7.1.bb b/meta/recipes-devtools/python/python-setuptools_18.7.1.bb
new file mode 100644
index 0000000000..1cc877491e
--- /dev/null
+++ b/meta/recipes-devtools/python/python-setuptools_18.7.1.bb
@@ -0,0 +1,47 @@
1SUMMARY = "Downloads, builds, installs, upgrades, and uninstalls Python packages"
2HOMEPAGE = "https://pypi.python.org/pypi/setuptools"
3SECTION = "devel/python"
4LICENSE = "Python-2.0 | ZPL-2.0"
5LIC_FILES_CHKSUM = "file://setup.py;beginline=78;endline=78;md5=8a314270dd7a8dbca741775415f1716e"
6
7SRCNAME = "setuptools"
8
9PROVIDES = "python-distribute"
10
11DEPENDS += "python"
12DEPENDS_class-native += "python-native"
13
14inherit distutils
15
16SRC_URI = "https://pypi.python.org/packages/source/s/setuptools/setuptools-${PV}.tar.gz"
17SRC_URI[md5sum] = "a0984da9cd8d7b582e1fd7de67dfdbcc"
18SRC_URI[sha256sum] = "aff36c95035e0b311eacb1434e3f7e85f5ccaad477773847e582978f8f45bd74"
19UPSTREAM_CHECK_URI = "https://pypi.python.org/pypi/setuptools"
20
21S = "${WORKDIR}/${SRCNAME}-${PV}"
22
23
24DISTUTILS_INSTALL_ARGS += "--install-lib=${D}${libdir}/${PYTHON_DIR}/site-packages"
25
26do_install_prepend() {
27 install -d ${D}/${libdir}/${PYTHON_DIR}/site-packages
28}
29
30RDEPENDS_${PN} = "\
31 python-stringold \
32 python-email \
33 python-shell \
34 python-distutils \
35 python-compression \
36"
37
38RDEPENDS_${PN}_class-native = "\
39 python-distutils \
40 python-compression \
41"
42
43RREPLACES_${PN} = "python-distribute"
44RPROVIDES_${PN} = "python-distribute"
45RCONFLICTS_${PN} = "python-distribute"
46
47BBCLASSEXTEND = "native nativesdk"