summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python-setuptools_1.1.7.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/python/python-setuptools_1.1.7.bb')
-rw-r--r--meta/recipes-devtools/python/python-setuptools_1.1.7.bb40
1 files changed, 40 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python-setuptools_1.1.7.bb b/meta/recipes-devtools/python/python-setuptools_1.1.7.bb
new file mode 100644
index 0000000000..c00738c10f
--- /dev/null
+++ b/meta/recipes-devtools/python/python-setuptools_1.1.7.bb
@@ -0,0 +1,40 @@
1DESCRIPTION = "Download, build, install, upgrade, and uninstall Python packages"
2HOMEPAGE = "http://cheeseshop.python.org/pypi/setuptools"
3SECTION = "devel/python"
4LICENSE = "PSF"
5LIC_FILES_CHKSUM = "file://setup.py;beginline=107;endline=107;md5=8a314270dd7a8dbca741775415f1716e"
6
7SRCNAME = "setuptools"
8DEPENDS += "python"
9DEPENDS_class-native += "python-native"
10
11SRC_URI = "\
12 http://cheeseshop.python.org/packages/source/s/setuptools/${SRCNAME}-${PV}.tar.gz\
13"
14S = "${WORKDIR}/${SRCNAME}-${PV}"
15
16inherit distutils
17
18DISTUTILS_INSTALL_ARGS += "--install-lib=${D}${libdir}/${PYTHON_DIR}/site-packages"
19
20do_install_prepend() {
21 install -d ${D}/${libdir}/${PYTHON_DIR}/site-packages
22}
23
24RDEPENDS_${PN} = "\
25 python-stringold \
26 python-email \
27 python-shell \
28 python-distutils \
29 python-compression \
30"
31
32RDEPENDS_${PN}_class-native = "\
33 python-distutils \
34 python-compression \
35"
36
37SRC_URI[md5sum] = "1f33594d25d574a1640ffb84667c6759"
38SRC_URI[sha256sum] = "b35e3d7c79cfdb5b38cfc71f4b0deab4350c1176fc4bb05bfa8945504ecfb028"
39
40BBCLASSEXTEND = "native"