summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python-setuptools_0.6c11.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/python/python-setuptools_0.6c11.bb')
-rw-r--r--meta/recipes-devtools/python/python-setuptools_0.6c11.bb31
1 files changed, 31 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python-setuptools_0.6c11.bb b/meta/recipes-devtools/python/python-setuptools_0.6c11.bb
new file mode 100644
index 0000000000..75bce3f720
--- /dev/null
+++ b/meta/recipes-devtools/python/python-setuptools_0.6c11.bb
@@ -0,0 +1,31 @@
1DESCRIPTION = "Download, build, install, upgrade, and uninstall Python packages"
2HOMEPAGE = "http://cheeseshop.python.org/pypi/setuptools"
3SECTION = "devel/python"
4LICENSE = "PSF"
5LIC_FILES_CHKSUM = "file://setup.py;beginline=23;endline=23;md5=8a314270dd7a8dbca741775415f1716e"
6
7SRCNAME = "setuptools"
8PR = "ml2"
9DEPENDS += "python"
10DEPENDS_virtclass-native += "python-native"
11
12SRC_URI = "\
13 http://cheeseshop.python.org/packages/source/s/setuptools/${SRCNAME}-${PV}.tar.gz\
14"
15S = "${WORKDIR}/${SRCNAME}-${PV}"
16
17inherit distutils
18
19do_install_prepend() {
20 install -d ${D}/${libdir}/${PYTHON_DIR}/site-packages
21}
22
23RDEPENDS_${PN} = "\
24 python-distutils \
25 python-compression \
26"
27
28SRC_URI[md5sum] = "7df2a529a074f613b509fb44feefe74e"
29SRC_URI[sha256sum] = "630fea9b726320b73ee3ca6ff61732cb32675b0389be658080fe46383b87a1d3"
30
31BBCLASSEXTEND = "native"