summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python-scons_3.1.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/python/python-scons_3.1.0.bb')
-rw-r--r--meta/recipes-devtools/python/python-scons_3.1.0.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python-scons_3.1.0.bb b/meta/recipes-devtools/python/python-scons_3.1.0.bb
new file mode 100644
index 0000000000..b174050583
--- /dev/null
+++ b/meta/recipes-devtools/python/python-scons_3.1.0.bb
@@ -0,0 +1,24 @@
1SUMMARY = "Software Construction tool (make/autotools replacement)"
2SECTION = "devel/python"
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=37bb53a08e6beaea0c90e7821d731284"
5
6SRC_URI = "${SOURCEFORGE_MIRROR}/scons/scons-${PV}.tar.gz"
7SRC_URI[md5sum] = "e2fe9d16f81b0285b969238af4b552ff"
8SRC_URI[sha256sum] = "f3f548d738d4a2179123ecd744271ec413b2d55735ea7625a59b1b59e6cd132f"
9
10S = "${WORKDIR}/scons-${PV}"
11
12UPSTREAM_CHECK_URI = "http://scons.org/pages/download.html"
13UPSTREAM_CHECK_REGEX = "(?P<pver>\d+(\.\d+)+)\.tar"
14
15inherit setuptools
16
17RDEPENDS_${PN} = "\
18 python-fcntl \
19 python-io \
20 python-json \
21 python-subprocess \
22 python-shell \
23 python-pprint \
24 "