summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python-scons_2.5.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/python/python-scons_2.5.0.bb')
-rw-r--r--meta/recipes-devtools/python/python-scons_2.5.0.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python-scons_2.5.0.bb b/meta/recipes-devtools/python/python-scons_2.5.0.bb
new file mode 100644
index 0000000000..c0a1cd4948
--- /dev/null
+++ b/meta/recipes-devtools/python/python-scons_2.5.0.bb
@@ -0,0 +1,24 @@
1SUMMARY = "Software Construction tool (make/autotools replacement)"
2SECTION = "devel/python"
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=3a885dff6d14e4cd876d9008a09a42de"
5SRCNAME = "scons"
6
7SRC_URI = "https://files.pythonhosted.org/packages/source/s/${SRCNAME}/${SRCNAME}-${PV}.tar.gz"
8
9SRC_URI[md5sum] = "bda5530a70a41a7831d83c8b191c021e"
10SRC_URI[sha256sum] = "01f1b3d6023516a8e1b5e77799e5a82a23b32953b1102d339059ffeca8600493"
11
12UPSTREAM_CHECK_URI = "https://pypi.python.org/pypi/SCons/"
13UPSTREAM_CHECK_REGEX = "/scons/(?P<pver>(\d+[\.\-_]*)+)/"
14
15S = "${WORKDIR}/${SRCNAME}-${PV}"
16
17inherit setuptools
18
19RDEPENDS_${PN} = "\
20 python-fcntl \
21 python-io \
22 python-json \
23 python-subprocess \
24 "