summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python-scons_2.4.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/python/python-scons_2.4.1.bb')
-rw-r--r--meta/recipes-devtools/python/python-scons_2.4.1.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python-scons_2.4.1.bb b/meta/recipes-devtools/python/python-scons_2.4.1.bb
new file mode 100644
index 0000000000..096cf5c960
--- /dev/null
+++ b/meta/recipes-devtools/python/python-scons_2.4.1.bb
@@ -0,0 +1,22 @@
1SUMMARY = "Software Construction tool (make/autotools replacement)"
2SECTION = "devel/python"
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=23bc1530c55e9f0d1b709056bcea237d"
5SRCNAME = "scons"
6
7SRC_URI = "${SOURCEFORGE_MIRROR}/scons/scons-${PV}.tar.gz"
8
9SRC_URI[md5sum] = "9a0ddf33d9839f04380e0fae87cc4b40"
10SRC_URI[sha256sum] = "8fc4f42928c69bcbb33e1be94b646f2c700b659693fabc778c192d4d22f753a7"
11
12UPSTREAM_CHECK_URI = "http://sourceforge.net/projects/scons/files/scons/"
13UPSTREAM_CHECK_REGEX = "/scons/(?P<pver>(\d+[\.\-_]*)+)/"
14
15S = "${WORKDIR}/${SRCNAME}-${PV}"
16
17inherit distutils
18
19RDEPENDS_${PN} = "\
20 python-fcntl \
21 python-io \
22 "