summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python-pyrex_0.9.9.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/python/python-pyrex_0.9.9.bb')
-rw-r--r--meta/recipes-devtools/python/python-pyrex_0.9.9.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python-pyrex_0.9.9.bb b/meta/recipes-devtools/python/python-pyrex_0.9.9.bb
new file mode 100644
index 0000000000..c4dd2e69b0
--- /dev/null
+++ b/meta/recipes-devtools/python/python-pyrex_0.9.9.bb
@@ -0,0 +1,22 @@
1SUMMARY = "Language for writing Python extension modules"
2DESCRIPTION = "Pyrex is a language specially designed for writing Python extension modules. \
3It's designed to bridge the gap between the nice, high-level, easy-to-use world of Python \
4and the messy, low-level world of C."
5SECTION = "devel/python"
6LICENSE = "Apache-2.0"
7LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=771d472f53f933033f57eeee7808e5bd"
8SRCNAME = "Pyrex"
9PR = "r4"
10
11SRC_URI = "\
12 http://www.cosc.canterbury.ac.nz/greg.ewing/python/${SRCNAME}/${SRCNAME}-${PV}.tar.gz \
13 file://pyrex-fix-optimized-mode.patch \
14"
15
16SRC_URI[md5sum] = "515dee67d15d4393841e2d60e8341947"
17SRC_URI[sha256sum] = "5f87df06831d0b3412eb4bc9d3fc2ee7bfae1b913d7da8c23ab2bf5699fb6b50"
18S = "${WORKDIR}/${SRCNAME}-${PV}"
19
20inherit distutils
21
22FILES_${PN} += "${datadir}${base_libdir}/${PYTHON_DIR}/site-packages/Pyrex/Compiler/Lexicon.pickle"