diff options
Diffstat (limited to 'meta/recipes-devtools/python/python-pygtk_2.24.0.bb')
-rw-r--r-- | meta/recipes-devtools/python/python-pygtk_2.24.0.bb | 54 |
1 files changed, 54 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python-pygtk_2.24.0.bb b/meta/recipes-devtools/python/python-pygtk_2.24.0.bb new file mode 100644 index 0000000000..20d54a33e1 --- /dev/null +++ b/meta/recipes-devtools/python/python-pygtk_2.24.0.bb | |||
@@ -0,0 +1,54 @@ | |||
1 | DESCRIPTION = "Python GTK+ 2.17.x Bindings" | ||
2 | SECTION = "devel/python" | ||
3 | # needs gtk+ 2.17.x | ||
4 | DEPENDS = "gtk+ libglade python-pycairo python-pygobject" | ||
5 | RDEPENDS_${PN} = "python-shell python-pycairo python-pygobject" | ||
6 | PROVIDES = "python-pygtk2" | ||
7 | SRCNAME = "pygtk" | ||
8 | LICENSE = "LGPLv2.1" | ||
9 | LIC_FILES_CHKSUM = "file://COPYING;md5=a916467b91076e631dd8edb7424769c7" | ||
10 | |||
11 | SRC_URI = "ftp://ftp.gnome.org/pub/gnome/sources/pygtk/2.24/${SRCNAME}-${PV}.tar.bz2 \ | ||
12 | file://fix-gtkunixprint.patch \ | ||
13 | file://prevent_to_get_display_during_import.patch \ | ||
14 | file://nodocs.patch \ | ||
15 | file://acinclude.m4" | ||
16 | |||
17 | SRC_URI[md5sum] = "a1051d5794fd7696d3c1af6422d17a49" | ||
18 | SRC_URI[sha256sum] = "cd1c1ea265bd63ff669e92a2d3c2a88eb26bcd9e5363e0f82c896e649f206912" | ||
19 | |||
20 | S = "${WORKDIR}/${SRCNAME}-${PV}" | ||
21 | |||
22 | EXTRA_OECONF = "--disable-docs --with-python-includes=${STAGING_INCDIR}/../" | ||
23 | |||
24 | inherit autotools pkgconfig distutils-base | ||
25 | |||
26 | do_configure_prepend() { | ||
27 | install -m 0644 ${WORKDIR}/acinclude.m4 ${S}/ | ||
28 | sed -i \ | ||
29 | -e s:'`$PKG_CONFIG --variable defsdir pygobject-2.0`':\"${STAGING_DATADIR}/pygobject/2.0/defs\":g \ | ||
30 | -e s:'`$PKG_CONFIG --variable=pygtkincludedir pygobject-2.0`':\"${STAGING_INCDIR}/pygtk-2.0\":g \ | ||
31 | -e s:'`$PKG_CONFIG --variable=datadir pygobject-2.0`':\"${STAGING_DATADIR}\":g \ | ||
32 | -e s:'`$PKG_CONFIG --variable codegendir pygobject-2.0`':\"${STAGING_DATADIR}/pygobject/2.0/codegen\":g \ | ||
33 | -e s:'`$PKG_CONFIG --variable=fixxref pygobject-2.0`':\"${STAGING_DATADIR}/pygobject/xsl/fixxref.py\":g \ | ||
34 | ${S}/configure.ac | ||
35 | sed -i 's:tests docs:tests:' Makefile.am | ||
36 | } | ||
37 | |||
38 | # dirty fix #1: remove dependency on python-pygobject-dev | ||
39 | do_install_append() { | ||
40 | find ${D} -name "*.la"|xargs rm -f | ||
41 | rm -f ${D}/${bindir}/pygtk-codegen-2.0 | ||
42 | rm -rf ${D}/${libdir}/pkgconfig | ||
43 | } | ||
44 | |||
45 | # dirty fix #2: fix build system paths leaking in | ||
46 | require fix-path.inc | ||
47 | |||
48 | PACKAGES =+ "${PN}-demo" | ||
49 | FILES_${PN}-demo = " ${bindir}/pygtk-demo ${libdir}/pygtk " | ||
50 | RDEPENDS_${PN}-demo = "python-pygtk python-stringold python-lang" | ||
51 | |||
52 | # todo: revamp packaging, package demo seperatly | ||
53 | FILES_${PN}-dev += " ${libdir}/pygtk/2.0 ${bindir}/pygtk-* ${datadir}/pygtk/2.0" | ||
54 | |||