diff options
Diffstat (limited to 'meta/recipes-devtools/python/python-pygtk_2.17.0.bb')
-rw-r--r-- | meta/recipes-devtools/python/python-pygtk_2.17.0.bb | 42 |
1 files changed, 42 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python-pygtk_2.17.0.bb b/meta/recipes-devtools/python/python-pygtk_2.17.0.bb new file mode 100644 index 0000000000..ef63b51038 --- /dev/null +++ b/meta/recipes-devtools/python/python-pygtk_2.17.0.bb | |||
@@ -0,0 +1,42 @@ | |||
1 | DESCRIPTION = "Python GTK+ 2.17.x Bindings" | ||
2 | SECTION = "devel/python" | ||
3 | # needs gtk+ 2.17.x | ||
4 | DEPENDS = "gtk+ libglade python-pycairo python-pygobject" | ||
5 | RDEPENDS = "python-shell python-pycairo python-pygobject" | ||
6 | PROVIDES = "python-pygtk2" | ||
7 | SRCNAME = "pygtk" | ||
8 | LICENSE = "LGPL" | ||
9 | PR = "ml8.2" | ||
10 | |||
11 | SRC_URI = "ftp://ftp.gnome.org/pub/gnome/sources/pygtk/2.17/${SRCNAME}-${PV}.tar.bz2 \ | ||
12 | file://fix-gtkunixprint.patch \ | ||
13 | file://prevent_to_get_display_during_import.patch \ | ||
14 | file://nodocs.patch \ | ||
15 | file://acinclude.m4" | ||
16 | S = "${WORKDIR}/${SRCNAME}-${PV}" | ||
17 | |||
18 | EXTRA_OECONF = "--disable-docs --with-python-includes=${STAGING_INCDIR}/../" | ||
19 | |||
20 | inherit autotools pkgconfig distutils-base | ||
21 | |||
22 | do_configure_prepend() { | ||
23 | install -m 0644 ${WORKDIR}/acinclude.m4 ${S}/ | ||
24 | } | ||
25 | |||
26 | # dirty fix #1: remove dependency on python-pygobject-dev | ||
27 | do_install_append() { | ||
28 | find ${D} -name "*.la"|xargs rm -f | ||
29 | rm -f ${D}/${bindir}/pygtk-codegen-2.0 | ||
30 | rm -rf ${D}/${libdir}/pkgconfig | ||
31 | } | ||
32 | |||
33 | # dirty fix #2: fix build system paths leaking in | ||
34 | require fix-path.inc | ||
35 | |||
36 | PACKAGES =+ "${PN}-demo" | ||
37 | FILES_${PN}-demo = " ${bindir}/pygtk-demo ${libdir}/pygtk " | ||
38 | RDEPENDS_${PN}-demo = "python-pygtk python-stringold python-lang" | ||
39 | |||
40 | # todo: revamp packaging, package demo seperatly | ||
41 | FILES_${PN}-dev += " ${libdir}/pygtk/2.0 ${bindir}/pygtk-* ${datadir}/pygtk/2.0" | ||
42 | |||