summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python-pygobject_2.28.3.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/python/python-pygobject_2.28.3.bb')
-rw-r--r--meta/recipes-devtools/python/python-pygobject_2.28.3.bb39
1 files changed, 39 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python-pygobject_2.28.3.bb b/meta/recipes-devtools/python/python-pygobject_2.28.3.bb
new file mode 100644
index 0000000000..45a0603eb7
--- /dev/null
+++ b/meta/recipes-devtools/python/python-pygobject_2.28.3.bb
@@ -0,0 +1,39 @@
1SUMMARY = "Python GObject bindings"
2SECTION = "devel/python"
3LICENSE = "LGPLv2.1"
4LIC_FILES_CHKSUM = "file://COPYING;md5=a916467b91076e631dd8edb7424769c7"
5DEPENDS = "python python-pygobject-native libffi glib-2.0"
6DEPENDS_class-native = "python-native libffi-native glib-2.0-native"
7RDEPENDS_class-native = ""
8
9MAJ_VER = "${@d.getVar('PV',1).split('.')[0]}.${@d.getVar('PV',1).split('.')[1]}"
10
11SRC_URI = "${GNOME_MIRROR}/pygobject/${MAJ_VER}/pygobject-${PV}.tar.bz2 \
12 file://obsolete_automake_macros.patch \
13"
14
15SRC_URI[md5sum] = "aa64900b274c4661a5c32e52922977f9"
16SRC_URI[sha256sum] = "7da88c169a56efccc516cebd9237da3fe518a343095a664607b368fe21df95b6"
17S = "${WORKDIR}/pygobject-${PV}"
18
19EXTRA_OECONF += "--disable-introspection"
20
21PARALLEL_MAKEINST = ""
22
23inherit autotools distutils-base pkgconfig
24
25# necessary to let the call for python-config succeed
26export BUILD_SYS
27export HOST_SYS
28export STAGING_INCDIR
29export STAGING_LIBDIR
30
31PACKAGES += "${PN}-lib"
32
33RDEPENDS_${PN} += "python-textutils"
34
35FILES_${PN} = "${libdir}/python*"
36FILES_${PN}-lib = "${libdir}/lib*.so.*"
37FILES_${PN}-dev += "${bindir} ${datadir}"
38
39BBCLASSEXTEND = "native"