diff options
Diffstat (limited to 'meta/recipes-devtools/python/python-pycurl_7.19.5.1.bb')
-rw-r--r-- | meta/recipes-devtools/python/python-pycurl_7.19.5.1.bb | 39 |
1 files changed, 39 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python-pycurl_7.19.5.1.bb b/meta/recipes-devtools/python/python-pycurl_7.19.5.1.bb new file mode 100644 index 0000000000..0d0effef60 --- /dev/null +++ b/meta/recipes-devtools/python/python-pycurl_7.19.5.1.bb | |||
@@ -0,0 +1,39 @@ | |||
1 | SUMMARY = "Python bindings for libcurl" | ||
2 | HOMEPAGE = "http://pycurl.sourceforge.net/" | ||
3 | SECTION = "devel/python" | ||
4 | LICENSE = "LGPLv2.1+ | MIT" | ||
5 | LIC_FILES_CHKSUM = "file://README.rst;beginline=166;endline=181;md5=57e5ab0c0f964533fc59d93dec5695bb \ | ||
6 | file://COPYING-LGPL;md5=3579a9fd0221d49a237aaa33492f988c \ | ||
7 | file://COPYING-MIT;md5=e8200955c773b2a0fd6cea36ea5e87be" | ||
8 | |||
9 | DEPENDS = "curl python" | ||
10 | RDEPENDS_${PN} = "python-core curl" | ||
11 | SRCNAME = "pycurl" | ||
12 | |||
13 | SRC_URI = "\ | ||
14 | http://${SRCNAME}.sourceforge.net/download/${SRCNAME}-${PV}.tar.gz;name=archive \ | ||
15 | file://no-static-link.patch \ | ||
16 | " | ||
17 | |||
18 | SRC_URI[archive.md5sum] = "f44cd54256d7a643ab7b16e3f409b26b" | ||
19 | SRC_URI[archive.sha256sum] = "6e9770f80459757f73bd71af82fbb29cd398b38388cdf1beab31ea91a331bc6c" | ||
20 | S = "${WORKDIR}/${SRCNAME}-${PV}" | ||
21 | |||
22 | inherit distutils | ||
23 | |||
24 | # need to export these variables for python-config to work | ||
25 | export BUILD_SYS | ||
26 | export HOST_SYS | ||
27 | export STAGING_INCDIR | ||
28 | export STAGING_LIBDIR | ||
29 | |||
30 | BBCLASSEXTEND = "native" | ||
31 | |||
32 | # Ensure the docstrings are generated as make clean will remove them | ||
33 | do_compile_prepend() { | ||
34 | ${STAGING_BINDIR_NATIVE}/${PYTHON_PN}-native/${PYTHON_PN} setup.py docstrings | ||
35 | } | ||
36 | |||
37 | do_install_append() { | ||
38 | rm -rf ${D}${datadir}/share | ||
39 | } | ||