summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python-pycurl_7.19.3.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/python/python-pycurl_7.19.3.1.bb')
-rw-r--r--meta/recipes-devtools/python/python-pycurl_7.19.3.1.bb34
1 files changed, 34 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python-pycurl_7.19.3.1.bb b/meta/recipes-devtools/python/python-pycurl_7.19.3.1.bb
new file mode 100644
index 0000000000..02d0ae9be0
--- /dev/null
+++ b/meta/recipes-devtools/python/python-pycurl_7.19.3.1.bb
@@ -0,0 +1,34 @@
1SUMMARY = "Python bindings for libcurl"
2HOMEPAGE = "http://pycurl.sourceforge.net/"
3SECTION = "devel/python"
4LICENSE = "LGPLv2.1+ | MIT"
5LIC_FILES_CHKSUM = "file://README.rst;beginline=148;endline=163;md5=57e5ab0c0f964533fc59d93dec5695bb \
6 file://COPYING-LGPL;md5=3579a9fd0221d49a237aaa33492f988c \
7 file://COPYING-MIT;md5=e8200955c773b2a0fd6cea36ea5e87be"
8
9DEPENDS = "curl python"
10RDEPENDS_${PN} = "python-core curl"
11SRCNAME = "pycurl"
12
13SRC_URI = "\
14 http://${SRCNAME}.sourceforge.net/download/${SRCNAME}-${PV}.tar.gz;name=archive \
15 file://no-static-link.patch \
16"
17
18SRC_URI[archive.md5sum] = "6df8fa7fe8b680d93248da1f8d4fcd12"
19SRC_URI[archive.sha256sum] = "c0d673fe99a9de07239eabe77c798f1b043f60c02afaec1430ceaf59d7501a4f"
20S = "${WORKDIR}/${SRCNAME}-${PV}"
21
22inherit distutils
23
24# need to export these variables for python-config to work
25export BUILD_SYS
26export HOST_SYS
27export STAGING_INCDIR
28export STAGING_LIBDIR
29
30BBCLASSEXTEND = "native"
31
32do_install_append() {
33 rm -rf ${D}${datadir}/share
34}