summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python-pycurl_7.19.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/python/python-pycurl_7.19.0.bb')
-rw-r--r--meta/recipes-devtools/python/python-pycurl_7.19.0.bb29
1 files changed, 29 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python-pycurl_7.19.0.bb b/meta/recipes-devtools/python/python-pycurl_7.19.0.bb
new file mode 100644
index 0000000000..1a04767266
--- /dev/null
+++ b/meta/recipes-devtools/python/python-pycurl_7.19.0.bb
@@ -0,0 +1,29 @@
1DESCRIPTION = "libcurl python bindings."
2HOMEPAGE = "http://pycurl.sourceforge.net/"
3SECTION = "devel/python"
4PRIORITY = "optional"
5LICENSE = "LGPLv2.1+ | MIT"
6LIC_FILES_CHKSUM = "file://README;endline=13;md5=fbfe545b1869617123a08c0983ef17b2 \
7 file://COPYING;md5=3579a9fd0221d49a237aaa33492f988c \
8 file://COPYING2;md5=ffaa1e283b7f9bf5aafd8d45db6f7518"
9
10DEPENDS = "curl python"
11RDEPENDS = "python-core curl"
12SRCNAME = "pycurl"
13PR = "r0"
14
15SRC_URI = "\
16 http://${SRCNAME}.sourceforge.net/download/${SRCNAME}-${PV}.tar.gz;name=archive \
17 file://no-static-link.patch;patch=1 \
18"
19S = "${WORKDIR}/${SRCNAME}-${PV}"
20
21inherit distutils
22
23# need to export these variables for python-config to work
24export BUILD_SYS
25export HOST_SYS
26export STAGING_INCDIR
27export STAGING_LIBDIR
28
29BBCLASSEXTEND = "native"