summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python-pycairo_1.8.10.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/python/python-pycairo_1.8.10.bb')
-rw-r--r--meta/recipes-devtools/python/python-pycairo_1.8.10.bb31
1 files changed, 0 insertions, 31 deletions
diff --git a/meta/recipes-devtools/python/python-pycairo_1.8.10.bb b/meta/recipes-devtools/python/python-pycairo_1.8.10.bb
deleted file mode 100644
index 02ec353f0a..0000000000
--- a/meta/recipes-devtools/python/python-pycairo_1.8.10.bb
+++ /dev/null
@@ -1,31 +0,0 @@
1DESCRIPTION = "Python Bindings for the Cairo canvas library"
2HOMEPAGE = "http://cairographics.org/pycairo"
3BUGTRACKER = "http://bugs.freedesktop.org"
4SECTION = "python-devel"
5LICENSE = "LGPLv2.1 & MPL-1"
6LIC_FILES_CHKSUM = "file://COPYING;md5=f2e071ab72978431b294a0d696327421"
7# cairo >= 1.8.8
8DEPENDS = "cairo"
9PR = "r2"
10
11SRC_URI = "http://cairographics.org/releases/py2cairo-${PV}.tar.gz"
12
13SRC_URI[md5sum] = "87421a6a70304120555ba7ba238f3dc3"
14SRC_URI[sha256sum] = "b15f71019e42e06d86f7e8fe5587f07c3de5a59a6c3a071b25fe100796dbcd56"
15S = "${WORKDIR}/pycairo-${PV}"
16
17inherit distutils pkgconfig
18
19do_compile_prepend() {
20#fix the installation path of __init__.py
21#It was going in the sysroot instead of target install location
22 sed -i -e "s#dsy.get_python_lib()#'${D}${PYTHON_SITEPACKAGES_DIR}'#" ${S}/setup.py
23}
24
25do_install_append () {
26 install -d ${D}${includedir}
27 install -d ${D}${libdir}
28 mv ${D}${datadir}/include/* ${D}${includedir}
29 mv ${D}${datadir}/lib/* ${D}${libdir}
30 sed -i -e 's#prefix=.*#prefix=${prefix}#' ${D}${libdir}/pkgconfig/pycairo.pc
31}