summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python-pycairo_1.8.10.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/python/python-pycairo_1.8.10.bb')
-rw-r--r--meta/recipes-devtools/python/python-pycairo_1.8.10.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python-pycairo_1.8.10.bb b/meta/recipes-devtools/python/python-pycairo_1.8.10.bb
new file mode 100644
index 0000000000..1ff603875a
--- /dev/null
+++ b/meta/recipes-devtools/python/python-pycairo_1.8.10.bb
@@ -0,0 +1,22 @@
1DESCRIPTION = "Python Bindings for the Cairo canvas library"
2HOMEPAGE = "http://cairographics.org/pycairo"
3BUGTRACKER = "http://bugs.freedesktop.org"
4SECTION = "python-devel"
5LICENSE = "LGPLv2.1 & MPLv1.1"
6LIC_FILES_CHKSUM = "file://COPYING;md5=f2e071ab72978431b294a0d696327421"
7# cairo >= 1.8.8
8DEPENDS = "cairo"
9PR = "ml0"
10
11SRC_URI = "http://cairographics.org/releases/py2cairo-${PV}.tar.gz"
12S = "${WORKDIR}/pycairo-${PV}"
13
14inherit distutils pkgconfig
15
16do_install_append () {
17 install -d ${D}${includedir}
18 install -d ${D}${libdir}
19 mv ${D}${datadir}/include/* ${D}${includedir}
20 mv ${D}${datadir}/lib/* ${D}${libdir}
21 sed -i -e 's#prefix=.*#prefix=${prefix}#' ${D}${libdir}/pkgconfig/pycairo.pc
22}