summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python-pycairo_1.10.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/python/python-pycairo_1.10.0.bb')
-rw-r--r--meta/recipes-devtools/python/python-pycairo_1.10.0.bb41
1 files changed, 41 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python-pycairo_1.10.0.bb b/meta/recipes-devtools/python/python-pycairo_1.10.0.bb
new file mode 100644
index 0000000000..70fe25c1a1
--- /dev/null
+++ b/meta/recipes-devtools/python/python-pycairo_1.10.0.bb
@@ -0,0 +1,41 @@
1SUMMARY = "Python bindings for the Cairo canvas library"
2HOMEPAGE = "http://cairographics.org/pycairo"
3BUGTRACKER = "http://bugs.freedesktop.org"
4SECTION = "python-devel"
5LICENSE = "LGPLv2.1 & MPL-1.1"
6LIC_FILES_CHKSUM = "file://COPYING;md5=f2e071ab72978431b294a0d696327421 \
7 file://COPYING-LGPL-2.1;md5=fad9b3332be894bab9bc501572864b29 \
8 file://COPYING-MPL-1.1;md5=bfe1f75d606912a4111c90743d6c7325"
9
10# cairo >= 1.8.8
11DEPENDS = "cairo"
12PR = "r2"
13
14SRC_URI = "http://cairographics.org/releases/py2cairo-${PV}.tar.bz2"
15
16SRC_URI[md5sum] = "20337132c4ab06c1146ad384d55372c5"
17SRC_URI[sha256sum] = "d30439f06c2ec1a39e27464c6c828b6eface3b22ee17b2de05dc409e429a7431"
18
19S = "${WORKDIR}/py2cairo-${PV}"
20
21inherit distutils pkgconfig
22
23BBCLASSEXTEND = "native"
24
25do_configure() {
26 BUILD_SYS=${BUILD_SYS} HOST_SYS=${HOST_SYS} ./waf configure --prefix=${D}${prefix} --libdir=${D}${libdir}
27}
28
29do_compile() {
30 ./waf build ${PARALLEL_MAKE}
31}
32
33do_install() {
34 ./waf install
35 sed \
36 -e 's:@prefix@:${prefix}:' \
37 -e 's:@VERSION@:${PV}:' \
38 -e 's:@includedir@:${includedir}:' \
39 pycairo.pc.in > pycairo.pc
40 install -m 0644 pycairo.pc ${D}${libdir}/pkgconfig/
41}