summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python-numpy_1.7.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/python/python-numpy_1.7.0.bb')
-rw-r--r--meta/recipes-devtools/python/python-numpy_1.7.0.bb99
1 files changed, 99 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python-numpy_1.7.0.bb b/meta/recipes-devtools/python/python-numpy_1.7.0.bb
new file mode 100644
index 0000000000..d4fd279230
--- /dev/null
+++ b/meta/recipes-devtools/python/python-numpy_1.7.0.bb
@@ -0,0 +1,99 @@
1SUMMARY = "A sophisticated Numeric Processing Package for Python"
2SECTION = "devel/python"
3LICENSE = "PSF"
4LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=f87832d854acbade6e9f5c601c8b30b1"
5PR = "r1"
6
7SRC_URI = "${SOURCEFORGE_MIRROR}/numpy/numpy-${PV}.tar.gz \
8 file://no-host-paths.patch \
9 ${CONFIGFILESURI} "
10
11CONFIGFILESURI ?= ""
12
13CONFIGFILESURI_aarch64 = " \
14 file://config.h \
15 file://_numpyconfig.h \
16"
17CONFIGFILESURI_arm = " \
18 file://config.h \
19 file://numpyconfig.h \
20"
21CONFIGFILESURI_armeb = " \
22 file://config.h \
23 file://numpyconfig.h \
24"
25CONFIGFILESURI_mipsel = " \
26 file://config.h \
27 file://numpyconfig.h \
28"
29CONFIGFILESURI_i586 = " \
30 file://config.h \
31 file://numpyconfig.h \
32"
33CONFIGFILESURI_x86-64 = " \
34 file://config.h \
35 file://_numpyconfig.h \
36"
37CONFIGFILESURI_mips = " \
38 file://config.h \
39 file://_numpyconfig.h \
40"
41CONFIGFILESURI_powerpc = " \
42 file://config.h \
43 file://_numpyconfig.h \
44"
45CONFIGFILESURI_powerpc64 = " \
46 file://config.h \
47 file://_numpyconfig.h \
48"
49CONFIGFILESURI_mips64 = " \
50 file://config.h \
51 file://_numpyconfig.h \
52"
53CONFIGFILESURI_mips64n32 = " \
54 file://config.h \
55 file://_numpyconfig.h \
56"
57
58S = "${WORKDIR}/numpy-${PV}"
59
60inherit distutils
61
62# Make the build fail and replace *config.h with proper one
63# This is a ugly, ugly hack - Koen
64do_compile_prepend_class-target() {
65 BUILD_SYS=${BUILD_SYS} HOST_SYS=${HOST_SYS} \
66 ${STAGING_BINDIR_NATIVE}/python-native/python setup.py build ${DISTUTILS_BUILD_ARGS} || \
67 true
68 cp ${WORKDIR}/*config.h ${S}/build/$(ls ${S}/build | grep src)/numpy/core/include/numpy/
69}
70
71FILES_${PN}-staticdev += "${PYTHON_SITEPACKAGES_DIR}/numpy/core/lib/*.a"
72
73SRC_URI[md5sum] = "4fa54e40b6a243416f0248123b6ec332"
74SRC_URI[sha256sum] = "f4fa70b7edbab65ee6432eb63743f5489f1919c614632b20b2fb45aa7e682ac6"
75
76# install what is needed for numpy.test()
77RDEPENDS_${PN} = "python-unittest \
78 python-difflib \
79 python-pprint \
80 python-pickle \
81 python-shell \
82 python-nose \
83 python-doctest \
84 python-datetime \
85 python-distutils \
86 python-misc \
87 python-mmap \
88 python-netclient \
89 python-numbers \
90 python-pydoc \
91 python-pkgutil \
92 python-email \
93 python-subprocess \
94 python-compression \
95"
96
97RDEPENDS_${PN}_class-native = ""
98
99BBCLASSEXTEND = "native nativesdk"