summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python-numpy_1.7.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/python/python-numpy_1.7.0.bb')
-rw-r--r--meta/recipes-devtools/python/python-numpy_1.7.0.bb87
1 files changed, 87 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python-numpy_1.7.0.bb b/meta/recipes-devtools/python/python-numpy_1.7.0.bb
new file mode 100644
index 0000000000..f8974cf802
--- /dev/null
+++ b/meta/recipes-devtools/python/python-numpy_1.7.0.bb
@@ -0,0 +1,87 @@
1SUMMARY = "A sophisticated Numeric Processing Package for Python"
2SECTION = "devel/python"
3LICENSE = "PSF"
4LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=f87832d854acbade6e9f5c601c8b30b1"
5PR = "r1"
6
7SRC_URI = "${SOURCEFORGE_MIRROR}/numpy/numpy-${PV}.tar.gz \
8 file://no-host-paths.patch \
9 ${CONFIGFILESURI} "
10
11CONFIGFILESURI ?= ""
12
13CONFIGFILESURI_aarch64 = " \
14 file://config.h \
15 file://_numpyconfig.h \
16"
17CONFIGFILESURI_arm = " \
18 file://config.h \
19 file://numpyconfig.h \
20"
21CONFIGFILESURI_armeb = " \
22 file://config.h \
23 file://numpyconfig.h \
24"
25CONFIGFILESURI_mipsel = " \
26 file://config.h \
27 file://numpyconfig.h \
28"
29CONFIGFILESURI_i586 = " \
30 file://config.h \
31 file://numpyconfig.h \
32"
33CONFIGFILESURI_x86-64 = " \
34 file://config.h \
35 file://_numpyconfig.h \
36"
37CONFIGFILESURI_mips = " \
38 file://config.h \
39 file://_numpyconfig.h \
40"
41CONFIGFILESURI_powerpc = " \
42 file://config.h \
43 file://_numpyconfig.h \
44"
45
46S = "${WORKDIR}/numpy-${PV}"
47
48inherit distutils
49
50# Make the build fail and replace *config.h with proper one
51# This is a ugly, ugly hack - Koen
52do_compile_prepend_class-target() {
53 BUILD_SYS=${BUILD_SYS} HOST_SYS=${HOST_SYS} \
54 ${STAGING_BINDIR_NATIVE}/python-native/python setup.py build ${DISTUTILS_BUILD_ARGS} || \
55 true
56 cp ${WORKDIR}/*config.h ${S}/build/$(ls ${S}/build | grep src)/numpy/core/include/numpy/
57}
58
59FILES_${PN}-staticdev += "${PYTHON_SITEPACKAGES_DIR}/numpy/core/lib/*.a"
60
61SRC_URI[md5sum] = "4fa54e40b6a243416f0248123b6ec332"
62SRC_URI[sha256sum] = "f4fa70b7edbab65ee6432eb63743f5489f1919c614632b20b2fb45aa7e682ac6"
63
64# install what is needed for numpy.test()
65RDEPENDS_${PN} = "python-unittest \
66 python-difflib \
67 python-pprint \
68 python-pickle \
69 python-shell \
70 python-nose \
71 python-doctest \
72 python-datetime \
73 python-distutils \
74 python-misc \
75 python-mmap \
76 python-netclient \
77 python-numbers \
78 python-pydoc \
79 python-pkgutil \
80 python-email \
81 python-subprocess \
82 python-compression \
83"
84
85RDEPENDS_${PN}_class-native = ""
86
87BBCLASSEXTEND = "native nativesdk"