summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python-numpy_1.10.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/python/python-numpy_1.10.1.bb')
-rw-r--r--meta/recipes-devtools/python/python-numpy_1.10.1.bb98
1 files changed, 98 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python-numpy_1.10.1.bb b/meta/recipes-devtools/python/python-numpy_1.10.1.bb
new file mode 100644
index 0000000000..693020efdc
--- /dev/null
+++ b/meta/recipes-devtools/python/python-numpy_1.10.1.bb
@@ -0,0 +1,98 @@
1SUMMARY = "A sophisticated Numeric Processing Package for Python"
2SECTION = "devel/python"
3LICENSE = "PSF"
4LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=9f4e88b5748e8313caaf33d081ce65a3"
5
6SRC_URI = "${SOURCEFORGE_MIRROR}/numpy/numpy-${PV}.tar.gz \
7 file://0001-Don-t-search-usr-and-so-on-for-libraries-by-default-.patch \
8 ${CONFIGFILESURI} "
9
10CONFIGFILESURI ?= ""
11
12CONFIGFILESURI_aarch64 = " \
13 file://config.h \
14 file://_numpyconfig.h \
15"
16CONFIGFILESURI_arm = " \
17 file://config.h \
18 file://numpyconfig.h \
19"
20CONFIGFILESURI_armeb = " \
21 file://config.h \
22 file://numpyconfig.h \
23"
24CONFIGFILESURI_mipsel = " \
25 file://config.h \
26 file://numpyconfig.h \
27"
28CONFIGFILESURI_x86 = " \
29 file://config.h \
30 file://numpyconfig.h \
31"
32CONFIGFILESURI_x86-64 = " \
33 file://config.h \
34 file://_numpyconfig.h \
35"
36CONFIGFILESURI_mips = " \
37 file://config.h \
38 file://_numpyconfig.h \
39"
40CONFIGFILESURI_powerpc = " \
41 file://config.h \
42 file://_numpyconfig.h \
43"
44CONFIGFILESURI_powerpc64 = " \
45 file://config.h \
46 file://_numpyconfig.h \
47"
48CONFIGFILESURI_mips64 = " \
49 file://config.h \
50 file://_numpyconfig.h \
51"
52CONFIGFILESURI_mips64n32 = " \
53 file://config.h \
54 file://_numpyconfig.h \
55"
56
57S = "${WORKDIR}/numpy-${PV}"
58
59inherit distutils
60
61# Make the build fail and replace *config.h with proper one
62# This is a ugly, ugly hack - Koen
63do_compile_prepend_class-target() {
64 BUILD_SYS=${BUILD_SYS} HOST_SYS=${HOST_SYS} \
65 ${STAGING_BINDIR_NATIVE}/python-native/python setup.py build ${DISTUTILS_BUILD_ARGS} || \
66 true
67 cp ${WORKDIR}/*config.h ${S}/build/$(ls ${S}/build | grep src)/numpy/core/include/numpy/
68}
69
70FILES_${PN}-staticdev += "${PYTHON_SITEPACKAGES_DIR}/numpy/core/lib/*.a"
71
72SRC_URI[md5sum] = "3fed2b50906bc19018cec5fa26168aa5"
73SRC_URI[sha256sum] = "8b9f453f29ce96a14e625100d3dcf8926301d36c5f622623bf8820e748510858"
74
75# install what is needed for numpy.test()
76RDEPENDS_${PN} = "python-unittest \
77 python-difflib \
78 python-pprint \
79 python-pickle \
80 python-shell \
81 python-nose \
82 python-doctest \
83 python-datetime \
84 python-distutils \
85 python-misc \
86 python-mmap \
87 python-netclient \
88 python-numbers \
89 python-pydoc \
90 python-pkgutil \
91 python-email \
92 python-subprocess \
93 python-compression \
94"
95
96RDEPENDS_${PN}_class-native = ""
97
98BBCLASSEXTEND = "native nativesdk"