diff options
Diffstat (limited to 'meta/recipes-devtools/python/python-native_2.7.9.bb')
-rw-r--r-- | meta/recipes-devtools/python/python-native_2.7.9.bb | 61 |
1 files changed, 61 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python-native_2.7.9.bb b/meta/recipes-devtools/python/python-native_2.7.9.bb new file mode 100644 index 0000000000..dfde36129f --- /dev/null +++ b/meta/recipes-devtools/python/python-native_2.7.9.bb | |||
@@ -0,0 +1,61 @@ | |||
1 | require python.inc | ||
2 | |||
3 | EXTRANATIVEPATH += "bzip2-native" | ||
4 | DEPENDS = "openssl-native bzip2-replacement-native zlib-native readline-native sqlite3-native" | ||
5 | PR = "${INC_PR}.1" | ||
6 | |||
7 | SRC_URI += "\ | ||
8 | file://05-enable-ctypes-cross-build.patch \ | ||
9 | file://10-distutils-fix-swig-parameter.patch \ | ||
10 | file://11-distutils-never-modify-shebang-line.patch \ | ||
11 | file://12-distutils-prefix-is-inside-staging-area.patch \ | ||
12 | file://debug.patch \ | ||
13 | file://unixccompiler.patch \ | ||
14 | file://nohostlibs.patch \ | ||
15 | file://multilib.patch \ | ||
16 | file://add-md5module-support.patch \ | ||
17 | file://builddir.patch \ | ||
18 | file://parallel-makeinst-create-bindir.patch \ | ||
19 | " | ||
20 | S = "${WORKDIR}/Python-${PV}" | ||
21 | |||
22 | FILESEXTRAPATHS =. "${FILE_DIRNAME}/${PN}:" | ||
23 | |||
24 | inherit native | ||
25 | |||
26 | RPROVIDES += "python-distutils-native python-compression-native python-textutils-native python-codecs-native python-core-native" | ||
27 | |||
28 | EXTRA_OECONF_append = " --bindir=${bindir}/${PN}" | ||
29 | |||
30 | EXTRA_OEMAKE = '\ | ||
31 | BUILD_SYS="" \ | ||
32 | HOST_SYS="" \ | ||
33 | LIBC="" \ | ||
34 | STAGING_LIBDIR=${STAGING_LIBDIR_NATIVE} \ | ||
35 | STAGING_INCDIR=${STAGING_INCDIR_NATIVE} \ | ||
36 | ' | ||
37 | |||
38 | do_configure_prepend() { | ||
39 | autoreconf --verbose --install --force --exclude=autopoint Modules/_ctypes/libffi || bbnote "_ctypes failed to autoreconf" | ||
40 | } | ||
41 | |||
42 | do_install() { | ||
43 | oe_runmake 'DESTDIR=${D}' install | ||
44 | install -d ${D}${bindir}/${PN} | ||
45 | install -m 0755 Parser/pgen ${D}${bindir}/${PN} | ||
46 | |||
47 | # Make sure we use /usr/bin/env python | ||
48 | for PYTHSCRIPT in `grep -rIl ${bindir}/${PN}/python ${D}${bindir}/${PN}`; do | ||
49 | sed -i -e '1s|^#!.*|#!/usr/bin/env python|' $PYTHSCRIPT | ||
50 | done | ||
51 | |||
52 | # Add a symlink to the native Python so that scripts can just invoke | ||
53 | # "nativepython" and get the right one without needing absolute paths | ||
54 | # (these often end up too long for the #! parser in the kernel as the | ||
55 | # buffer is 128 bytes long). | ||
56 | ln -s python-native/python ${D}${bindir}/nativepython | ||
57 | |||
58 | # We don't want modules in ~/.local being used in preference to those | ||
59 | # installed in the native sysroot, so disable user site support. | ||
60 | sed -i -e 's,^\(ENABLE_USER_SITE = \).*,\1False,' ${D}${libdir}/python${PYTHON_MAJMIN}/site.py | ||
61 | } | ||