summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python-native_2.7.3.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/python/python-native_2.7.3.bb')
-rw-r--r--meta/recipes-devtools/python/python-native_2.7.3.bb44
1 files changed, 44 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python-native_2.7.3.bb b/meta/recipes-devtools/python/python-native_2.7.3.bb
new file mode 100644
index 0000000000..50bf894d0c
--- /dev/null
+++ b/meta/recipes-devtools/python/python-native_2.7.3.bb
@@ -0,0 +1,44 @@
1require python.inc
2DEPENDS = "openssl-native bzip2-full-native zlib-native readline-native sqlite3-native"
3PR = "${INC_PR}.0"
4
5SRC_URI += "file://04-default-is-optimized.patch \
6 file://05-enable-ctypes-cross-build.patch \
7 file://06-ctypes-libffi-fix-configure.patch \
8 file://10-distutils-fix-swig-parameter.patch \
9 file://11-distutils-never-modify-shebang-line.patch \
10 file://12-distutils-prefix-is-inside-staging-area.patch \
11 file://debug.patch \
12 file://unixccompiler.patch \
13 file://nohostlibs.patch \
14 file://multilib.patch \
15 file://add-md5module-support.patch \
16 "
17S = "${WORKDIR}/Python-${PV}"
18
19inherit native
20
21RPROVIDES += "python-distutils-native python-compression-native python-textutils-native python-core-native"
22
23EXTRA_OEMAKE = '\
24 BUILD_SYS="" \
25 HOST_SYS="" \
26 LIBC="" \
27 STAGING_LIBDIR=${STAGING_LIBDIR_NATIVE} \
28 STAGING_INCDIR=${STAGING_INCDIR_NATIVE} \
29'
30
31do_configure_prepend() {
32 autoreconf --verbose --install --force --exclude=autopoint Modules/_ctypes/libffi || bbnote "_ctypes failed to autoreconf"
33}
34
35do_install() {
36 oe_runmake 'DESTDIR=${D}' install
37 install -d ${D}${bindir}/
38 install -m 0755 Parser/pgen ${D}${bindir}/
39
40 # Make sure we use /usr/bin/env python
41 for PYTHSCRIPT in `grep -rIl ${bindir}/python ${D}${bindir}`; do
42 sed -i -e '1s|^#!.*|#!/usr/bin/env python|' $PYTHSCRIPT
43 done
44}