summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python-native_2.7.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/python/python-native_2.7.2.bb')
-rw-r--r--meta/recipes-devtools/python/python-native_2.7.2.bb43
1 files changed, 43 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python-native_2.7.2.bb b/meta/recipes-devtools/python/python-native_2.7.2.bb
new file mode 100644
index 0000000000..6b90d5b891
--- /dev/null
+++ b/meta/recipes-devtools/python/python-native_2.7.2.bb
@@ -0,0 +1,43 @@
1require python.inc
2DEPENDS = "openssl-native bzip2-full-native zlib-native readline-native sqlite3-native"
3PR = "${INC_PR}.0"
4
5SRC_URI += "file://04-default-is-optimized.patch \
6 file://05-enable-ctypes-cross-build.patch \
7 file://06-ctypes-libffi-fix-configure.patch \
8 file://10-distutils-fix-swig-parameter.patch \
9 file://11-distutils-never-modify-shebang-line.patch \
10 file://12-distutils-prefix-is-inside-staging-area.patch \
11 file://debug.patch \
12 file://unixccompiler.patch \
13 file://nohostlibs.patch \
14 file://multilib.patch "
15S = "${WORKDIR}/Python-${PV}"
16
17inherit native
18
19EXTRA_OEMAKE = '\
20 BUILD_SYS="" \
21 HOST_SYS="" \
22 LIBC="" \
23 STAGING_LIBDIR=${STAGING_LIBDIR_NATIVE} \
24 STAGING_INCDIR=${STAGING_INCDIR_NATIVE} \
25'
26
27do_configure_prepend() {
28 autoreconf --verbose --install --force --exclude=autopoint Modules/_ctypes/libffi || bbnote "_ctypes failed to autoreconf"
29}
30
31do_install() {
32 oe_runmake 'DESTDIR=${D}' install
33 install -d ${D}${bindir}/
34 install -m 0755 Parser/pgen ${D}${bindir}/
35
36 # Make sure we use /usr/bin/env python
37 for PYTHSCRIPT in `grep -rIl ${bindir}/python ${D}${bindir}`; do
38 sed -i -e '1s|^#!.*|#!/usr/bin/env python|' $PYTHSCRIPT
39 done
40
41 ln -sf python ${D}${bindir}/python2
42
43}